Wednesday, November 25th, 2015

- It is currently Wed Nov 25, 2015 6:20 pm

All times are UTC - 4 hours

Jump to:  

Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Mon Apr 09, 2012 9:00 pm 
Riding on 13's

Joined: Mon May 03, 2010 5:56 pm
Posts: 8
hey guys ,I dont know if anyone of you all ever experience this problem but my abs and handbrake light on my dash come on and go off at period intervals.Whenever this happens my turbo timer starts blinking and sometimes my radio, the speedometer drops down to zero and then back to the normal speed.Is as if the car cuts off and comes on back.

Any advice

Share on FacebookShare on Twitter
PostPosted: Tue Apr 10, 2012 3:02 pm 
Riding on 16's
User avatar

Joined: Sun Apr 10, 2005 7:22 pm
Posts: 1225
Location: VIP
sounds like a bad/loose ground.

check the battery terminals, and other main wiring for loose connections.

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 4 hours

Who is online

Registered users: *KRONIK*, 2311, 323tuner, 88sins, Alexa [Bot], Allergic2BunnyEars, bigjohn, bigval, Bing [Bot], blessup, bonafide, computercentral, cueball1990, damien66, darknight, diworldboss1234, dogpound, driveshaft, fasco, gastly369, germanspy, Google [Bot], indianlove, Insanex3, ismithx, JayyXXII, kerron01, KHANRICH, lionking, Mad Cone, MichaelPrasad, mitisubishiboi22, MSNbot Media, Naka, ninjabilly, offroader, Online Android Companion, PariaMan, partscentral, prrjohn, racedriverpro, Ranger1982, reynold1, rmrunner, ron_28, selwyn, Starrboucisse, steven923, SUPERMAN2, Ted_v2, trinikhanos, tropi_flakes, vijay7050, wootang, Yahoo [Bot], zorced, zulu atomic

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group