Saturday, October 25th, 2014



- It is currently Sat Oct 25, 2014 3:39 pm

All times are UTC - 4 hours


Jump to:  


Post new topic Reply to topic  [ 5 posts ] 
Author Message
RadDogJr
 Post subject: Fumes while AC on
PostPosted: Thu Nov 18, 2010 2:32 am 
Offline
Street 2NR
User avatar

Joined: Sun Dec 24, 2006 1:58 pm
Posts: 82
Location: San Fernando
Anyone ever experienced fumes coming in through the air condition vent after a hard acceleration. This happens sometimes for a short period of time even though the vents are closed and the unit is on AUTO circulation mode. It tends to have a slightly burnt scent.

I normally clear the scent by depressing the vent/circulate button to open and close the vents.

Any sensible suggestions will be appreciated.


Share on FacebookShare on Twitter
Top
 Profile  
 
INDAVID WORKSHOP
 Post subject: Re: Fumes while AC on
PostPosted: Thu Nov 18, 2010 4:08 am 
Offline
3NE 2NR Power Seller
User avatar

Joined: Sat Mar 29, 2008 6:44 pm
Posts: 304
Location: Trinidad
check the sealing strip on the flapper for fresh air/recycle, the seal could be damaged causing the blower unit to pull air from outside even when in recycle mode


Top
 Profile  
 
zaria
 Post subject: Re: Fumes while AC on
PostPosted: Sat Nov 20, 2010 8:07 am 
Offline
Sweet on this forum

Joined: Mon Jan 22, 2007 8:42 am
Posts: 383
Location: cunupia
I had the burning smell from G/Vitara,LM replaced the ac filter which was dirty
the smell is now only faintly there.An Ac guy told me its a resistor when fan is in low speed that heats up
and gives the smell and nothing can be done to stop it.


Top
 Profile  
 
RadDogJr
 Post subject: Re: Fumes while AC on
PostPosted: Sat Nov 20, 2010 2:37 pm 
Offline
Street 2NR
User avatar

Joined: Sun Dec 24, 2006 1:58 pm
Posts: 82
Location: San Fernando
Thanks for the responses 868newtrini and zaria. I will check both options when I get the chance


Top
 Profile  
 
RadDogJr
 Post subject: Re: Fumes while AC on
PostPosted: Sat Nov 20, 2010 2:43 pm 
Offline
Street 2NR
User avatar

Joined: Sun Dec 24, 2006 1:58 pm
Posts: 82
Location: San Fernando
[quote="zaria"]I had the burning smell from G/Vitara,LM replaced the ac filter which was dirty
the smell is now only faintly there.An Ac guy told me its a resistor when fan is in low speed that heats up
and gives the smell and nothing can be done to stop it.[/quote]

My vehicle is also a GV so I'll try Zari's solution first and compare the responses of the AC with the fan at low and high speeds.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 4 hours


Who is online

Registered users: <=xjemler=>, 25stouring, 8292, ajawill, alexatherton5, ali19801, allblacks, Annan Jugoon, autozam, barzee, BassMekanik, Bing [Bot], bluebird1986, brianramdial, chit8238, cutthroatInt, d_ad_man, Dj_Bee, Dmentalcase29, dude2014, Exabot [Bot], GabrielBad, gamefreak187, Gas brains and Tire feet, God Zeus, Google [Bot], irunfreeport, K74T, Karim Khan, knorgriff, krazyykidd, LevinBZR, mero, MSNbot Media, nightman22, nismaniac, nismo007, nismo_demon, Patman, pilot1950, PiMan, qwerty, r@ndy_S, scenic108, scotty_buttons, shivab, Speed Racer 101, src1983, straightup, thesoomz, thestroke, Titan Procurement Ltd., torque 4 so, toyolink, trinifabulous, Trinilex, TriP, turboturnsmeon2, vtec powwa, WarrLordd, Yahoo [Bot]


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
3NE-2NR