Wednesday, October 1st, 2014



- It is currently Wed Oct 01, 2014 6:19 pm

All times are UTC - 4 hours


Forum rules


This forum is for discussions on Trucks and Pickups only!
DO NOT POST ADS IN HERE
WTB (Want to buy), LF (Looking for), EOI (Expression of Interest) or FS (For sale) topics etc will be deleted.
If you are looking for a part please search or post in the Auto Parts Classifieds.
Please keep all discussion professional and technical. Opinions are welcomed, however trolling, spamming and bashing will not be tolerated.

Jump to:  


Post new topic Reply to topic  [ 830 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6 ... 28  Next
Author Message
l200
 Post subject:
PostPosted: Thu Oct 01, 2009 11:01 am 
Offline
3NE 2NR for life
User avatar

Joined: Wed Sep 03, 2008 9:45 pm
Posts: 121
Location: couva
Hi speedaholic, I don,t kno if the pump is the same but here are the pics, good luck.


Image


Image


Image


Top
 Profile  
 
venum
 Post subject:
PostPosted: Sat Oct 03, 2009 8:03 am 
Offline
3NE2NR Diesel Boyz
User avatar

Joined: Fri May 07, 2004 3:19 pm
Posts: 5761
Location: San Fernando
On my K74 the choke/throttle cable connected directly to my accelerator pedal

When you pull it, the accelerator depresses


Top
 Profile  
 
madman2961
 Post subject:
PostPosted: Fri Oct 09, 2009 1:55 pm 
Offline
3NE 2NR for life
User avatar

Joined: Sun Mar 05, 2006 8:56 am
Posts: 244
Location: Tunapuna
hey y'all since fuel is a big thing i does have to check my water trap under the fuel filter ever so often cause the wire to the harness not there and that is how i bought the van. i would like to know the cost and where i could get the original part.

ppl say to cut the wire and get a male and female connector and wire it up.
i will do that if i cannot find the original water with harness

please help out the ones from the K34 are also compatible as my friend has one and as for me i have a K74T


Top
 Profile  
 
ryanm
 Post subject:
PostPosted: Sat Oct 10, 2009 8:10 am 
Offline
Street 2NR
User avatar

Joined: Sat Feb 10, 2007 4:00 pm
Posts: 77
Location: Curepe
There is a parts place on Pasea Road close to the bus route on the same compound of a Grocery. He has the part to screw onto the bottom of the diesel filter complete with harness. I think i paid $45 for mine


Top
 Profile  
 
madman2961
 Post subject:
PostPosted: Sun Oct 11, 2009 12:10 pm 
Offline
3NE 2NR for life
User avatar

Joined: Sun Mar 05, 2006 8:56 am
Posts: 244
Location: Tunapuna
ryanm,thanks man i will check them out


Top
 Profile  
 
l200
 Post subject:
PostPosted: Sun Oct 11, 2009 2:31 pm 
Offline
3NE 2NR for life
User avatar

Joined: Wed Sep 03, 2008 9:45 pm
Posts: 121
Location: couva
Hi speedaholic, I don't kno if the k34 choke could work on the k74 engine, because it is connected directly to the pedal, and not the pump........ But once you have all the parts that came wit the k74 pump, you could probably hook up the automatic choke.

If you take the vacuum from off the alternator,......... ( on a diesel engine, vacuum comes from a vacuum pump, which in our case is connected to the alternator),..... it should have a place to connect the vacuum line, then the vacuum is connected to a "dash spot"??? (not sure if thats the correct name) an that is then connected to the solenoid that is on the pump, which then controls the idle. I got the pics of a k74 pump, but wasn't able to get a pic of the dash spot.

If I understand correctly, the "dash spot", when connected, will sense when the vacuum drops and will the open the vacuum to the solenoid, which will then raise the idle, to compensate for the drop in vacuum.


Image




Image




Image



venum,madman2961, and anyone with a k74, could you please confirm this, I am fairly new to the diesel engines, and still learning, so not sure if all the info is correct.

These pics are off a turbo k74, wit a top mounted inter-cooler.


Top
 Profile  
 
venum
 Post subject:
PostPosted: Sun Oct 11, 2009 11:25 pm 
Offline
3NE2NR Diesel Boyz
User avatar

Joined: Fri May 07, 2004 3:19 pm
Posts: 5761
Location: San Fernando
Will check when I get a chance


Top
 Profile  
 
madman2961
 Post subject:
PostPosted: Mon Oct 12, 2009 8:19 am 
Offline
3NE 2NR for life
User avatar

Joined: Sun Mar 05, 2006 8:56 am
Posts: 244
Location: Tunapuna
is your idle up working speedaholic, i will check and see it the K34 and K74 pedals are the same. if so you might be able to try and get the K74 choke assembly and equip it to the pedal like the K74


Top
 Profile  
 
madman2961
 Post subject:
PostPosted: Tue Oct 13, 2009 9:55 am 
Offline
3NE 2NR for life
User avatar

Joined: Sun Mar 05, 2006 8:56 am
Posts: 244
Location: Tunapuna
how long do your glow plugs last?
i have to change mine!!!

i will put up pics of the process!!


Top
 Profile  
 
l200
 Post subject:
PostPosted: Tue Oct 13, 2009 7:43 pm 
Offline
3NE 2NR for life
User avatar

Joined: Wed Sep 03, 2008 9:45 pm
Posts: 121
Location: couva
Hi speedaholic hope you get through,....... madman2961, my mechanic said that after market glow plugs last abt a year, but original plugs will last longer. I guess once you notice that the van not starting normally or idling rough, and even giving out a little white smoke when cold, the plugs are starting to fail.

I have recently scraped out my ignition system wiring, and cleaned all the connectors, with some contact cleaner and also changed my battery pole clamps, and cut off the old ends,..... it made a huge difference.


The reason for the cleaning is that, I had changed my glow plugs, and it worked well for a while ( 1 week) then I had problems hard starting, so I would have to heat the plugs twice, when cold starting......I was told that I needed a new starter by an electrician, because the starter sounded "lazy" an is in need of a service..........

Well to make a long story short, starter turning fast, and de van starting in a one on mornings. So I would recommend to all the older model vans to give their electrical a clean out every now an then.


Top
 Profile  
 
madman2961
 Post subject:
PostPosted: Thu Oct 15, 2009 8:36 am 
Offline
3NE 2NR for life
User avatar

Joined: Sun Mar 05, 2006 8:56 am
Posts: 244
Location: Tunapuna
speedaholic, i think they does say that black smoke is too much diesel going in. so i guess you just have to change your air filter that same thing happening to me but i changed my filter and it reduced. so i need to recalibrate the fuel pump.

l200, thanks for the advice, but the glow plugs i bought were CRAP!!! i paid $45 for one and it lasted a month. i bought original HKT PM-75 and i hope these last longer. i paid $300 for the four.

Also i did not take pics cause my friends duck out on me Tuesday evening (to hold the camera) and i had to go to work Wednesday morning so i changed it before i went and had no company and was on borrowed time.
Sorry about that i will try to organize something with regards to that.


Top
 Profile  
 
venum
 Post subject:
PostPosted: Thu Oct 15, 2009 9:01 am 
Offline
3NE2NR Diesel Boyz
User avatar

Joined: Fri May 07, 2004 3:19 pm
Posts: 5761
Location: San Fernando
madman2961 wrote:

l200, thanks for the advice, but the glow plugs i bought were CRAP!!! i paid $45 for one and it lasted a month. i bought original HKT PM-75 and i hope these last longer. i paid $300 for the four.


let that be a lesson to the rest of allyuh

cheap glow plugs are crap, buy the good stuff one time

madman did you check teh price in DM :?:


Top
 Profile  
 
madman2961
 Post subject:
PostPosted: Thu Oct 15, 2009 9:17 am 
Offline
3NE 2NR for life
User avatar

Joined: Sun Mar 05, 2006 8:56 am
Posts: 244
Location: Tunapuna
venum wrote:
madman2961 wrote:

l200, thanks for the advice, but the glow plugs i bought were CRAP!!! i paid $45 for one and it lasted a month. i bought original HKT PM-75 and i hope these last longer. i paid $300 for the four.


let that be a lesson to the rest of allyuh

cheap glow plugs are crap, buy the good stuff one time

madman did you check teh price in DM :?:


i did not check the price at DM. do you know it? as you now asked that i am kinda interested in the price.
i guessing $300 for 1


Top
 Profile  
 
venum
 Post subject:
PostPosted: Sun Oct 18, 2009 11:02 pm 
Offline
3NE2NR Diesel Boyz
User avatar

Joined: Fri May 07, 2004 3:19 pm
Posts: 5761
Location: San Fernando
Next time I have cause to pass in DM I will find out the price


Top
 Profile  
 
cutthroatInt
 Post subject:
PostPosted: Fri Nov 13, 2009 10:24 am 
Offline
Trinituner Peong
User avatar

Joined: Sat Feb 11, 2006 1:24 am
Posts: 446
Location: 3ne*dad
People, i getting some serious steering issues on the k34 4x2.

the entire front end is new.. did it over again.

all ball joints, all ends, all bushings, cambered and aligned back.


blasted van going where it wants on roads with depressions. you see that south bound lane from Caroni flyover to Munroe Road flyover, if i dont hold the steering with both hands and brace my right hand on the door, this van will change 3 lanes before u can say Patrick Manning.

smooth roads not a problem atall..

so since the whole front end is new, i believe the only variable left is the steering box. when vehicle is going naught miles per hour, and steering is rocked side to side, i get bout 2-3 inches of free play. but the ting is, the steering box adjustment screw is now in all the way and still no major reduction of "drifting" on roads with depressions. (It just so happens that ALL roads in Trinidad have depressions). So i seeing real strain anywhere i going.

im scouting around for another steering box for the van...

if any of you K34 L200 4x2 guys have an extra box on the ground... help out a bredda....


or if someone can open it up and see whats the problem. this is a foreign used box thats on the van now. i still hav the original box on the ground. maybe someone can use the two to get one good working powersteering box.

i would like to know what you guys think bout this situation....

any advice or suggestions are welcome.


Top
 Profile  
 
cutthroatInt
 Post subject: l200
PostPosted: Sun Nov 15, 2009 10:56 pm 
Offline
Trinituner Peong
User avatar

Joined: Sat Feb 11, 2006 1:24 am
Posts: 446
Location: 3ne*dad
help


Top
 Profile  
 
l200
 Post subject:
PostPosted: Wed Nov 18, 2009 1:20 pm 
Offline
3NE 2NR for life
User avatar

Joined: Wed Sep 03, 2008 9:45 pm
Posts: 121
Location: couva
hi cutthroatInt, i also have the same problem, just not as bad (abt 2" of play), and was doing some searching around, no luck with finding any. I was told that a machine shop can repair the worn gears inside and have you back as new. But since you have one one the ground you could carry that one to repair......... DM has the parts, or so I was told when I checked them abt two months ago, but they need to see it, Thats what they told me, but all the parts come in a kit.

I will continue to look, if i find anything I'll let you know.


Top
 Profile  
 
cutthroatInt
 Post subject:
PostPosted: Fri Feb 05, 2010 5:19 pm 
Offline
Trinituner Peong
User avatar

Joined: Sat Feb 11, 2006 1:24 am
Posts: 446
Location: 3ne*dad
more problems!

my 4d56 non turbo engine bunnin oil and apparently back pressuring now. as its pressuring up the sump and oil is pitchin out the dipstick on idle. i had to tie down the dip stick with piece of wire.

so after talkin to a mechanic i was told this is happenening because the rings are going and compression is leaking from the combustion chamber down the cylinder leading to burning oil and "compression" pressuring up the sump pan forcing oil out any crevice.

i will get some more opinions but i want to put tings in place as i dont ting the engine will last much longer. its driving but i can feel its less powerful now.

its been 2 days now since oil began pitchin out the dipstick..

who kno more bout dis situation please add ur comments.

i posted a thread lookin for 4d56 turbo engine... or non turbo head and block...

cos i kno for sure its starting to call for an engine job.

which wud u recommend? a build over? or jus buy a foreign used engine?

thanks




Speedaholic, i eh change the timing belts yet so the radiator shroud aint off yet.


Top
 Profile  
 
venum
 Post subject:
PostPosted: Fri Feb 05, 2010 11:05 pm 
Offline
3NE2NR Diesel Boyz
User avatar

Joined: Fri May 07, 2004 3:19 pm
Posts: 5761
Location: San Fernando
cutthroatInt, make that decision when you ahve the price of teh rebuild and price of another engine

remember with new engine, cater to change seals and timing belts etc before installing


Top
 Profile  
 
cutthroatInt
 Post subject:
PostPosted: Sat Feb 06, 2010 12:27 pm 
Offline
Trinituner Peong
User avatar

Joined: Sat Feb 11, 2006 1:24 am
Posts: 446
Location: 3ne*dad
wrt to meh problem, it burn half quart oil in 2 days....


Top
 Profile  
 
AllTrac
 Post subject:
PostPosted: Sat Feb 06, 2010 7:54 pm 
Offline
TriniTuner Crew
User avatar

Joined: Thu Apr 17, 2003 11:43 pm
Posts: 21089
Location: squatting in the curl rack
guys im reading on the l200 uk forum that the 4g56 is plagued with a blown headgasket issue and warped heads, anyone experienced this? they the k74 is the only model affected


Top
 Profile  
 
venum
 Post subject:
PostPosted: Sun Feb 07, 2010 8:43 pm 
Offline
3NE2NR Diesel Boyz
User avatar

Joined: Fri May 07, 2004 3:19 pm
Posts: 5761
Location: San Fernando
That's 4D56

I'm a member on that forum (same name)

The older K34's in the UK had this problem a lot, not so much the K74's

The K74's that were chipped using the early chips used to suffer this almost as a surity

The stock ones not so much

Prob cuz the chips were essentially piggy-backs and the 4D56 wasn't designed to take the constant and increased stress caused by the chip

haven't come across many stock K74's locally with the problem

The K74's do suffer from a crank pully weakness - it breaks (seems to be a weak design flaw)

Know of a couple that it happened to


Top
 Profile  
 
ryanm
 Post subject:
PostPosted: Mon Feb 08, 2010 5:58 am 
Offline
Street 2NR
User avatar

Joined: Sat Feb 10, 2007 4:00 pm
Posts: 77
Location: Curepe
never really heard bout the problem happening randomly. I know that if it overheats then for sure blown head gasket :shock:

the previous owner of mine had removed the thermostat as this was a precautionary measure.

vennum - is the k74 2005 model electronic fuel injection? if so i didn't realize.
did you get through with the inspection and did licensing office give trouble with the fog lights?


Top
 Profile  
 
MadCrix
 Post subject:
PostPosted: Mon Feb 08, 2010 9:14 am 
Offline
3NE 2NR Moderator
User avatar

Joined: Mon Mar 22, 2004 2:46 pm
Posts: 3474
Location: Missing the ride
yea venum, meh carnk bolt descided to give way christmas time.
fixed now.

when van was down i decided to service the injector pump.

now i get it back and noticed that when it cold very little black smoke.

when the engone warms up, i get black smoke all teh time.

the egr vavle vacumm hose is unplugged and seald off. apparantly all the emission vacum hosed are unplugged.

anyone can help me sort out this problem i will owe them for life.


Top
 Profile  
 
venum
 Post subject:
PostPosted: Mon Feb 08, 2010 10:36 am 
Offline
3NE2NR Diesel Boyz
User avatar

Joined: Fri May 07, 2004 3:19 pm
Posts: 5761
Location: San Fernando
ryanm wrote:
venum - is the k74 2005 model electronic fuel injection? if so i didn't realize.
did you get through with the inspection and did licensing office give trouble with the fog lights?


teh owners manual says that it is electronic

buts as far as I see it still takes timing off teh crank (from timing belt)

i ent reach for inspection (have a defective front indicator now) but I will be removing all teh auxillary lights before I go

I have them wired for easy removal


Top
 Profile  
 
AllTrac
 Post subject:
PostPosted: Mon Feb 08, 2010 1:49 pm 
Offline
TriniTuner Crew
User avatar

Joined: Thu Apr 17, 2003 11:43 pm
Posts: 21089
Location: squatting in the curl rack
ment to say 4d56, sorry. Thanks for the reassurance guys


Top
 Profile  
 
ryanm
 Post subject:
PostPosted: Mon Feb 08, 2010 9:31 pm 
Offline
Street 2NR
User avatar

Joined: Sat Feb 10, 2007 4:00 pm
Posts: 77
Location: Curepe
the electricals look just like my k34 though. thanks
will do more research


Top
 Profile  
 
venum
 Post subject:
PostPosted: Mon Feb 08, 2010 9:44 pm 
Offline
3NE2NR Diesel Boyz
User avatar

Joined: Fri May 07, 2004 3:19 pm
Posts: 5761
Location: San Fernando
K74 and K34 very much alike

different chassis

suspension is almost the same

front is pretty identical, rear has different lift springs (but they are interchangeable)

engine has slight differences (K34 is direct turbo, K74 is IC Turbo)

interior is totally different

electrical is slightly different


Top
 Profile  
 
venum
 Post subject:
PostPosted: Tue Feb 09, 2010 12:05 am 
Offline
3NE2NR Diesel Boyz
User avatar

Joined: Fri May 07, 2004 3:19 pm
Posts: 5761
Location: San Fernando
might

I never checked

some model vehicles e.g. Hilux have different power steering setup between the 2wd and 4wd

because of the positioning of teh front diff

never checked with the l200


Top
 Profile  
 
venum
 Post subject:
PostPosted: Tue Feb 09, 2010 2:35 pm 
Offline
3NE2NR Diesel Boyz
User avatar

Joined: Fri May 07, 2004 3:19 pm
Posts: 5761
Location: San Fernando
Might be

I never investigated much with the 2WD models

So I can't really say


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 830 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6 ... 28  Next

All times are UTC - 4 hours


Who is online

Registered users: $0R@yA10, **JSJ**, 2WNBoost, Abraham2nd, astivinny, basstard, biggz99, Bing [Bot], blaine, Bobby~d, Brandon101, BrandonSingh, C.K.P, Carbon12, chris18, crabsouse, daron, Eagle, evolve-x, Exabot [Bot], Google [Bot], Google Feedfetcher, Groovemaster, hustla_ambition101, Hyperion, iamsam, ian, immortal, INHUMAN, Insanex3, Jammoh23, JDMplayers, jenjendaddy, Joshie23, kamakazi, kdb, keronlaptiste, kg494EJ-1, kliq, linkting, Lutch, Madmen_Productions, mali, markie boy, megadoc1, Michael Knight..., MicMar, morfire, narutouzamaki, natio, Nick367, nicks1, Nissian for life, Norton12005, optimusprime, pales, pilotman90, porker, ProgressiveTT, pyromaniax, Rainman, RapToR, ratedR, ReBeLz, ricarneaud2011, ryansk, Sai_2012, sammy111, sdm141, singh is king, SiR8081, spymaster1, sss16, starzz, STRESSOUT, stuartsc, stxxel, tallman7, Tech_Girl, teems1, towers58, toyotajumbie, trapstar, Trini_2NR, trinibourbon, tropi_flakes, troublemaker, welltuned, Winfield Augustus, X_Factor, Yahoo [Bot], ~Vēġó~


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
3NE-2NR