Thursday, July 24th, 2014



- It is currently Thu Jul 24, 2014 9:00 am

All times are UTC - 4 hours


Forum rules


This forum is for discussions on Trucks and Pickups only!
DO NOT POST ADS IN HERE
WTB (Want to buy), LF (Looking for), EOI (Expression of Interest) or FS (For sale) topics etc will be deleted.
If you are looking for a part please search or post in the Auto Parts Classifieds.
Please keep all discussion professional and technical. Opinions are welcomed, however trolling, spamming and bashing will not be tolerated.

Jump to:  


Post new topic Reply to topic  [ 12 posts ] 
Author Message
telfer
PostPosted: Thu Apr 05, 2012 9:15 pm 
Offline
3NE 2NR for life
User avatar

Joined: Sun Nov 21, 2004 6:16 pm
Posts: 183
so my 3.0 hilux has in a KN filter this is the third time my van has gone into fail safe mode because of the air flow sensor being dirty
Has anyone getting this or has ever gotten this problem


Share on FacebookShare on Twitter
Top
 Profile  
 
Big Z
PostPosted: Thu Apr 05, 2012 9:30 pm 
Offline
3NE 2NR Power Seller
User avatar

Joined: Wed Aug 11, 2004 9:58 pm
Posts: 1942
Location: Mobile# 734-7669 Amsoil, Redline, Royal Purple, Valvoline & Luberfiner, Fuel Injector Cleaning
1. K&N filters are oil based filters. It will cause your MAF to get dirty.
2. Most people over oil their K&N filters after cleaning. Follow the directions for your particular filter.
3. Most people like to wash K&N filters like they wash their car. Been using K&N drop in filters in two vehicles for about 40k km each. I have never washed the filters. A damp cloth is enough to wipe away the heavy dirt. Do this every oil change.
4. I clean my MAF probably every oil change.


Top
 Profile  
 
telfer
PostPosted: Fri Apr 06, 2012 10:42 am 
Offline
3NE 2NR for life
User avatar

Joined: Sun Nov 21, 2004 6:16 pm
Posts: 183
i am not using any oil the guy who I brought it from said alot of hilux owners sensors spoiled when they oiled it
normally they come pre oiled but not these


Top
 Profile  
 
323_wagon_dude
PostPosted: Fri Apr 06, 2012 11:48 am 
Offline
3NE2NR Diesel Boyz
User avatar

Joined: Thu Oct 30, 2003 8:03 pm
Posts: 752
Location: Right here
The K&Ns are oiled filters. Even when its new it has oil on it.

If your hilux is going into limp mode that often, you should clean the MAF sensor. Be very careful when you're cleaning it as it is fragile.

Also, I'd recommend when you clean and reoil the K&N, do not apply excessive oil, and let it sit for a day before you reinstall it in the truck. I had a spare original toyota paper filter that I would use while the K&N is sitting after being oiled.

I agree with Big Z, do not wash the filter too often. I cleaned and reoiled my filter ( and MAF Sensor) every other oil change.

Hope this helps.


Top
 Profile  
 
Aaron 2NR
PostPosted: Fri Apr 06, 2012 11:56 am 
Offline
2NR phototakerouter
User avatar

Joined: Sun Feb 22, 2004 9:28 am
Posts: 5690
i have mine for 7000km and didn't notice any loss in power yet....

can you shed some more light into your application because i spoke to quite a couple users and some experienced it, some never did. My dealer said they never had issues with k&n filters in any vehicle they service...

have you ever re-oiled? mileage used? was it installed when the truck was new? was teh maf sensor dirty before you put the filter in?


Top
 Profile  
 
roti102
PostPosted: Fri Apr 06, 2012 2:28 pm 
Offline
Street 2NR
User avatar

Joined: Wed Jan 25, 2006 8:56 am
Posts: 86
Use a K&N filter and let dirt in your engine causing premature wear and tear. Come on people, its common sense! More airflow means more dirt through your turbo and cylinder walls.


Top
 Profile  
 
Aaron 2NR
PostPosted: Fri Apr 06, 2012 3:04 pm 
Offline
2NR phototakerouter
User avatar

Joined: Sun Feb 22, 2004 9:28 am
Posts: 5690
Took my maf sensor out and cleaned it just for argument sake....cloth remained clean....


Attachments:
ImageUploadedByTapatalk1333739084.542674.jpg
ImageUploadedByTapatalk1333739084.542674.jpg [ 189.78 KiB | Viewed 624 times ]
Top
 Profile  
 
CD4Accord
PostPosted: Sat Apr 07, 2012 12:00 pm 
Offline
Riding on 17's
User avatar

Joined: Tue Dec 15, 2009 12:20 am
Posts: 1547
Try switching back to a normal filter for a while and see if you have similar problems..
If it works fine without the K+N, then sell that filth to the next person who wants to "gain massive power" on their 4 x 4...

Seriously speaking, it cannot be justified in a pick-up or 4 x 4


Top
 Profile  
 
madcoolieboy
PostPosted: Mon Apr 09, 2012 3:24 pm 
Offline
3NE 2NR for life
User avatar

Joined: Fri Mar 03, 2006 6:48 pm
Posts: 189
Location: arkham asylum for the criminally insane..Under the alias: 'SYKO'
which part dah MAF sensor dey? daiz de one way dey by the air filter housing?


Top
 Profile  
 
Aaron 2NR
PostPosted: Wed Apr 11, 2012 8:31 am 
Offline
2NR phototakerouter
User avatar

Joined: Sun Feb 22, 2004 9:28 am
Posts: 5690
OP gone silent


Top
 Profile  
 
telfer
PostPosted: Thu Apr 12, 2012 8:12 pm 
Offline
3NE 2NR for life
User avatar

Joined: Sun Nov 21, 2004 6:16 pm
Posts: 183
might have try going back orginal air filter


Top
 Profile  
 
3stagevtec
PostPosted: Fri Apr 13, 2012 2:41 am 
Offline
TriniTuner 24-7
User avatar

Joined: Wed Jul 12, 2006 1:57 pm
Posts: 9262
Location: killing two stones with one bird...
1) CRC makes a MAF Cleaner, I saw it available at Federal's in south.. Be careful when cleaning your MAF and use only products specifically designed for the job.

2) Lightly oil the K&N and do NOT clean it often! When it gets mildly dirty, that is actually a good thing as it improves its filtration ability. I would not recommend wiping the filter as that could force dirt deeper into the pores of the filter media.

3) Toyota did a great job at designing that engine and intake system! Far better than you could imagine. To be honest, if that was my personal ride, I'd use the regular paper filters as those have excellent flow and filtration abilities.. Don't buy too much into the air filter hype..


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ] 

All times are UTC - 4 hours


Who is online

Registered users: 20inchstrong, 5zigen, adesh72, ajayidk, aks, alpine, andy111, andy14171..., Audiopipe96, Auto Innovation, bigjohn, Bing [Bot], Bosse, caglowe, certified_dealer, ChristianRD, Crackpot, D.S.S, Dark-Man, Datacom, dawgscrew, directed, dj kev, Double R Auto, dougla_boy, Esharcangel, flesh645, frankjohn, Google [Bot], Google Adsense [Bot], greywhispering, honda123, Hope Academy Prep, jaggie, JDM_GUY, jhonnieblue, jose123, joshua smith, josiah97, Kaizen Autosound, karl, Ken zen, kerwinishere, killercow, kjaglal76v2, kliq, kual, lance100, link up, m_czar1993, Madhatter, MADMAN1, Majestic-12 [Bot], mammoo, MANIAC, mb27, Mercenary, midix76, mobilitytech, MobSpec, mon**, moti, Mr. Fixables, pete, preston4927, preysal audio shop, Prototype-Tuner, QualityKarz, Quantum, Rainman, rampy, RobertsHayden, Rockstar1911, Shortie, Slartibartfast, sonic100, sound vision, spirited721, Sultan, sweetface789, Topcat, tr1ad, TRAE, Turbo Corbeaux, turboconch2, turbod, turbofowl, turbosingh, Type Rated, U4EA, WM_Tuner, Yahoo [Bot], zanim1112


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
3NE-2NR