TriniTuner.com  |  Latest Event:  

Forums

Fixing My 1996 CIVIC

Fit, Civic, Integra, CR-V, Accord, Legend - Do NOT post FS or WTB here!!!

Moderator: 3ne2nr Mods

User avatar
nigie
Shifting into 6th
Posts: 2182
Joined: October 9th, 2006, 4:11 pm

Re: Fixing My 1996 CIVIC

Postby nigie » August 5th, 2014, 11:21 am

Preparing for drift.... :mrgreen:

Image

Image

Image

ebay......13 USD
Image

Image

Image

Free....
Image

Image

I can now see my tach on 7500 rpm.... :mrgreen: :mrgreen:
Image

Advertisement
User avatar
nigie
Shifting into 6th
Posts: 2182
Joined: October 9th, 2006, 4:11 pm

Re: Fixing My 1996 CIVIC

Postby nigie » March 5th, 2015, 9:00 pm

tried the 3pin to 4 pin alternator conversion.....partial success ....car barely idles at 350

User avatar
nigie
Shifting into 6th
Posts: 2182
Joined: October 9th, 2006, 4:11 pm

Re: Fixing My 1996 CIVIC

Postby nigie » July 4th, 2015, 9:49 pm

Anybody know where I can get a new straight pin distributor cap and rotor...tried the company and auto nation with no success

User avatar
nigie
Shifting into 6th
Posts: 2182
Joined: October 9th, 2006, 4:11 pm

Re: Fixing My 1996 CIVIC

Postby nigie » October 30th, 2015, 10:14 am

Yeah the rad was the culprit of overheating,,,and since reluctance to clean it by radiator men...trip by hyper v...and problem solved. :mrgreen:

Image

Image

Image

Image

Image

Image


Cooling like a cucumber plus i got the nifty oil cover and matching rad mount :mrgreen:

User avatar
JDM_GUY
Riding on 17's
Posts: 1558
Joined: January 24th, 2006, 7:39 pm
Contact:

Re: Fixing My 1996 CIVIC

Postby JDM_GUY » October 30th, 2015, 2:45 pm

looking good man. Keep up the wrenching.

User avatar
princejada
Street 2NR
Posts: 91
Joined: April 1st, 2013, 11:17 pm

Re: Fixing My 1996 CIVIC

Postby princejada » October 30th, 2015, 7:18 pm

What type of transmission oil u used ??

User avatar
nigie
Shifting into 6th
Posts: 2182
Joined: October 9th, 2006, 4:11 pm

Re: Fixing My 1996 CIVIC

Postby nigie » November 5th, 2015, 9:44 am

Halloween and young people dont mix ...geeez :(

bonnet 800
bumper 500
A/c condenser 1500
Regas 500
:( :( :(

Image

whiteboi wrote:What type of transmission oil u used ??


the replacement fluid for the Z they said they stop making the Z fluid

User avatar
JDM_GUY
Riding on 17's
Posts: 1558
Joined: January 24th, 2006, 7:39 pm
Contact:

Re: Fixing My 1996 CIVIC

Postby JDM_GUY » November 5th, 2015, 2:47 pm

Oh sheit sorry to see what happened.

User avatar
nigie
Shifting into 6th
Posts: 2182
Joined: October 9th, 2006, 4:11 pm

Re: Fixing My 1996 CIVIC

Postby nigie » November 12th, 2015, 3:18 pm

Alternator woes ..4pin ..3 pin issue ..eventually scrapped the 4 pin hook up where by the car was idling erratic and got a 3 pin regulator....works like a dream now :mrgreen:

Image

Advertisement

Return to “HONDA”

Who is online

Users browsing this forum: No registered users and 9 guests