TriniTuner.com  |  Latest Event:  

Forums

Need help with my d15b engine

Fit, Civic, Integra, CR-V, Accord, Legend - Do NOT post FS or WTB here!!!

Moderator: 3ne2nr Mods

User avatar
Kerrons101
Ricer
Posts: 19
Joined: May 11th, 2013, 6:27 pm

Need help with my d15b engine

Postby Kerrons101 » April 9th, 2014, 5:40 pm

I have a d15b engine that giving me some problems, my check light stays on when I start, I diagnose it more than one place they said it's the o2 sensor, can't locate foreign used sensors in the north. The problems I get with the engine is that when I put in reverse the car go high and low and when in neutral the rpm is above 1000 and when it's in drive idling it goes right. Down to 0. Question, can the o2 sensors cause this problem?? And if can u help me find someone sort this problem for me I'm willing to pay whatever it takes.

Advertisement
User avatar
enigma
Sweet on this forum
Posts: 356
Joined: September 23rd, 2005, 11:27 pm
Location: Here.
Contact:

Re: Need help with my d15b engine

Postby enigma » April 11th, 2014, 12:01 pm

Which O2 sensor does your engine carry? One or 4 wires?

User avatar
Kerrons101
Ricer
Posts: 19
Joined: May 11th, 2013, 6:27 pm

Re: Need help with my d15b engine

Postby Kerrons101 » August 25th, 2014, 1:17 pm

4 wires and it has 2 o2 sensors

User avatar
black start
TriniTuner 24-7
Posts: 7955
Joined: February 25th, 2010, 10:42 am
Location: conquering the pothole solodex

Re: Need help with my d15b engine

Postby black start » August 25th, 2014, 1:31 pm

Check on amazon for your 02 sensor!

User avatar
enigma
Sweet on this forum
Posts: 356
Joined: September 23rd, 2005, 11:27 pm
Location: Here.
Contact:

Re: Need help with my d15b engine

Postby enigma » August 25th, 2014, 1:38 pm

Do you know which sensor is throwing the code?

User avatar
1UZFE
punchin NOS
Posts: 4966
Joined: May 6th, 2011, 10:55 am

Re: Need help with my d15b engine

Postby 1UZFE » August 27th, 2014, 11:26 am

which d15b u have? vtech?

User avatar
rabiesebola
3NE 2NR for life
Posts: 155
Joined: August 20th, 2014, 2:31 pm

Re: Need help with my d15b engine

Postby rabiesebola » August 28th, 2014, 7:48 am

sounds like an electrical problem. i also had check light issues and also o2 sensor problems. i did my work by OBATECH on omeara road. located on the same street with garys bar. his name is Oba and number is 340-4037 (also on whatsapp)

User avatar
shermantank
Street 2NR
Posts: 90
Joined: March 17th, 2007, 12:17 pm

Re: Need help with my d15b engine

Postby shermantank » August 28th, 2014, 8:01 am

i also did work by oba and what i like is that he has most of the parts right there so u just walking with yur money...if arima to far u cud check Dave Auto Electrical as well located in tunapuna off the highway on the side with the hindu school.....his number is 702-4707

User avatar
Kerrons101
Ricer
Posts: 19
Joined: May 11th, 2013, 6:27 pm

Re: Need help with my d15b engine

Postby Kerrons101 » August 28th, 2014, 10:00 pm

It's a non Vtec engine cvt tranny, the sensors on the extractor
ImageUploadedByTriniTuner1409277587.338372.jpg

User avatar
Kerrons101
Ricer
Posts: 19
Joined: May 11th, 2013, 6:27 pm

Re: Need help with my d15b engine

Postby Kerrons101 » August 28th, 2014, 10:01 pm

shermantank wrote:i also did work by oba and what i like is that he has most of the parts right there so u just walking with yur money...if arima to far u cud check Dave Auto Electrical as well located in tunapuna off the highway on the side with the hindu school.....his number is 702-4707
don't think it's much of a electrical problem

User avatar
Kerrons101
Ricer
Posts: 19
Joined: May 11th, 2013, 6:27 pm

Re: Need help with my d15b engine

Postby Kerrons101 » August 28th, 2014, 10:02 pm

1UZFE wrote:which d15b u have? vtech?
I have the non vtec

User avatar
1UZFE
punchin NOS
Posts: 4966
Joined: May 6th, 2011, 10:55 am

Re: Need help with my d15b engine

Postby 1UZFE » August 28th, 2014, 10:06 pm

Did u get tru? I kno someone who has d same issue n dey did everything including buyin a new throttle body wit sensors n no improvements.

User avatar
Kerrons101
Ricer
Posts: 19
Joined: May 11th, 2013, 6:27 pm

Re: Need help with my d15b engine

Postby Kerrons101 » August 29th, 2014, 3:02 am

1UZFE wrote:Did u get tru? I kno someone who has d same issue n dey did everything including buyin a new throttle body wit sensors n no improvements.
I didn't get thru, I did all that too and my check light still on so d only thing I'm thinking now is changing the o2 sensors n moving 1 from d other as u could see in the pic they're too close to each other

User avatar
1UZFE
punchin NOS
Posts: 4966
Joined: May 6th, 2011, 10:55 am

Re: Need help with my d15b engine

Postby 1UZFE » August 29th, 2014, 5:22 am

Bro i think those sensors supposed to be cheap on amazon also of u get d part numbers u cud get dat right here on tuner on in d bamboo..

User avatar
Bullet_proof
Ricer
Posts: 26
Joined: August 18th, 2013, 8:52 am

Re: Need help with my d15b engine

Postby Bullet_proof » August 29th, 2014, 6:16 am

When the problem started? After tuning the car?

User avatar
Kerrons101
Ricer
Posts: 19
Joined: May 11th, 2013, 6:27 pm

Re: Need help with my d15b engine

Postby Kerrons101 » September 1st, 2014, 1:22 am

Bullet_proof wrote:When the problem started? After tuning the car?
problem started bout 4 months ago when u made ah stupid mistake by carrying the car to engine wash

User avatar
1UZFE
punchin NOS
Posts: 4966
Joined: May 6th, 2011, 10:55 am

Re: Need help with my d15b engine

Postby 1UZFE » September 1st, 2014, 8:10 am

Kerrons. Did u get around to change d sensor?

User avatar
Kerrons101
Ricer
Posts: 19
Joined: May 11th, 2013, 6:27 pm

Re: Need help with my d15b engine

Postby Kerrons101 » September 5th, 2014, 11:22 am

Yea guys I got thru with the problem, changed both sensors ( foreign used ones) and my check light is off, only thing tho when I'm on the highway n I mash down to do some numbers it comes back on. What could be the rel issue now???

User avatar
supercharged turbo
punchin NOS
Posts: 3064
Joined: January 19th, 2011, 6:53 pm
Location: turn around

Re: Need help with my d15b engine

Postby supercharged turbo » September 28th, 2014, 9:13 pm

I have that same problem..i think the oil might be too thick

Advertisement

Return to “HONDA”

Who is online

Users browsing this forum: No registered users and 4 guests