TriniTuner.com  |  Latest Event:  

Forums

clutch prob

Fit, Civic, Integra, CR-V, Accord, Legend - Do NOT post FS or WTB here!!!

Moderator: 3ne2nr Mods

hondablood
Chronic TriniTuner
Posts: 614
Joined: August 29th, 2010, 8:17 pm

clutch prob

Postby hondablood » July 13th, 2014, 10:08 pm

I intalled an 8lb fidanza flywheel recently in my zc engine and gearbox,i have a stage 4 act pp and clutch and since then i have been having clutch problems.I changed all seals oem in the clutch cylinder and the part that bolts to the front of the gear box and same results.Sometimes my clutch raises on its own to higher than usual and i have to mash half way to get clutch and sometimes it drops and i have to mash to the floor where it should be.Anyone ever experience this when installing a lightened flywheel?

Advertisement
User avatar
10-01
punchin NOS
Posts: 2940
Joined: September 29th, 2003, 4:24 pm

Re: clutch prob

Postby 10-01 » July 13th, 2014, 10:27 pm

u check the lines to see if any swelling when u mash the clutch

and wow u using a stage 4 PP and clutch on a NA ZC ?

User avatar
fass4drs
3NE 2NR for life
Posts: 143
Joined: October 29th, 2008, 8:11 pm

Re: clutch prob

Postby fass4drs » July 14th, 2014, 12:02 am

hondablood wrote:I intalled an 8lb fidanza flywheel recently in my zc engine and gearbox,i have a stage 4 act pp and clutch and since then i have been having clutch problems.I changed all seals oem in the clutch cylinder and the part that bolts to the front of the gear box and same results.Sometimes my clutch raises on its own to higher than usual and i have to mash half way to get clutch and sometimes it drops and i have to mash to the floor where it should be.Anyone ever experience this when installing a lightened flywheel?



possibly the cylinders are bad ..even if you changed the seals...check the lines for leaks or swelling ..very aggressive clutch for an NA d series.. have someone mash the clutch and look at the lines and cylinders ..particularly the slave.

hondablood
Chronic TriniTuner
Posts: 614
Joined: August 29th, 2010, 8:17 pm

Re: clutch prob

Postby hondablood » July 14th, 2014, 1:02 am

thanks,i will check it tmr,car is turbo btw,Will post an update

User avatar
red_dragon
Riding on 16's
Posts: 1255
Joined: April 8th, 2004, 6:43 pm

Re: clutch prob

Postby red_dragon » July 14th, 2014, 9:48 am

^ exedy clutch and PP ?

hondablood
Chronic TriniTuner
Posts: 614
Joined: August 29th, 2010, 8:17 pm

Re: clutch prob

Postby hondablood » July 14th, 2014, 10:28 am

act heavy duty pp and copper clutch spring loaded

User avatar
red_dragon
Riding on 16's
Posts: 1255
Joined: April 8th, 2004, 6:43 pm

Re: clutch prob

Postby red_dragon » July 14th, 2014, 10:39 am

the springs on the two pistons might also be weak or the cylinder walls are worn

also look at upgrading to a S200 master cylinder

User avatar
10-01
punchin NOS
Posts: 2940
Joined: September 29th, 2003, 4:24 pm

Re: clutch prob

Postby 10-01 » July 14th, 2014, 10:09 pm

red_dragon wrote:the springs on the two pistons might also be weak or the cylinder walls are worn

also look at upgrading to a S200 master cylinder


where u getting that master to buy locally ?

User avatar
red_dragon
Riding on 16's
Posts: 1255
Joined: April 8th, 2004, 6:43 pm

Re: clutch prob

Postby red_dragon » July 15th, 2014, 11:48 am

Correction
S2000 master cylinder

User avatar
10-01
punchin NOS
Posts: 2940
Joined: September 29th, 2003, 4:24 pm

Re: clutch prob

Postby 10-01 » July 15th, 2014, 7:47 pm

red_dragon wrote:Correction
S2000 master cylinder


correct me if im wrong im a noob but the s2000 carry a 5/8 master and the oem ek is 5/8 also why the upgrade ?

3774827048_021f71cf3f_o.jpg


s2000

VS

e3c6564a-f825-47ff-af1a-8883240ebeb3-800.jpg


ek

and then to pour brakes fluid u mite need a funnel because the placement is almost below the brakes master

hondablood
Chronic TriniTuner
Posts: 614
Joined: August 29th, 2010, 8:17 pm

Re: clutch prob

Postby hondablood » July 15th, 2014, 10:08 pm

thanks men,car going by the mech thursday,will let you all know

User avatar
red_dragon
Riding on 16's
Posts: 1255
Joined: April 8th, 2004, 6:43 pm

Re: clutch prob

Postby red_dragon » July 15th, 2014, 10:21 pm

Cool keep us posted

User avatar
10-01
punchin NOS
Posts: 2940
Joined: September 29th, 2003, 4:24 pm

Re: clutch prob

Postby 10-01 » July 16th, 2014, 6:30 pm

red_dragon wrote:Cool keep us posted


hmmmm still no response about the master :oops:

User avatar
Hirotoshi
Sweet on this forum
Posts: 299
Joined: December 14th, 2007, 10:05 am

Re: clutch prob

Postby Hirotoshi » July 17th, 2014, 2:19 pm

check rubber flex line & slave cylinder,replace if necessary. stage iv pressure plate is serious overkill for the street. try act heavy duty pp with street disc 8-)

User avatar
red_dragon
Riding on 16's
Posts: 1255
Joined: April 8th, 2004, 6:43 pm

Re: clutch prob

Postby red_dragon » July 17th, 2014, 3:33 pm

Act ss for NA but would start to slip with boost

boostfactory#1
Riding on 13's
Posts: 6
Joined: March 17th, 2013, 5:56 pm

Re: clutch prob

Postby boostfactory#1 » July 24th, 2014, 11:31 am

There may be A small leak, did you bleed the lines properly?

hondablood
Chronic TriniTuner
Posts: 614
Joined: August 29th, 2010, 8:17 pm

Re: clutch prob

Postby hondablood » July 25th, 2014, 12:03 am

i just gave that car a rest for 2 weeks yes before i get grey,will work on it saturday and keep you all posted

hondablood
Chronic TriniTuner
Posts: 614
Joined: August 29th, 2010, 8:17 pm

Re: clutch prob

Postby hondablood » August 6th, 2014, 11:09 pm

Ok tuners,finally got through with the clutch prob,there were no leaks,but someone told me that sometimes with age the rubber hose part of the clutch line collapses on the inside as they experiened a similar problem with their brakes line.I changed it and problem solved,did it over steel braided one time as i was not getting it to buy.Thanks all for the advice,another learning experience for me.

hondablood
Chronic TriniTuner
Posts: 614
Joined: August 29th, 2010, 8:17 pm

Re: clutch prob

Postby hondablood » August 7th, 2014, 3:04 pm

same problem start back again

Advertisement

Return to “HONDA”

Who is online

Users browsing this forum: No registered users and 4 guests