TriniTuner.com  |  Latest Event:  

Forums

SR20 CVT Tranny Problem

Sunny to Skyline - SR20, CA18, RB20-26, VG30 etc.

Moderator: 3ne2nr Mods

User avatar
killercow
3NE2NR is my LIFE
Posts: 731
Joined: July 29th, 2010, 6:33 pm
Location: Waze

SR20 CVT Tranny Problem

Postby killercow » May 11th, 2017, 4:54 pm

Need advice tuners. Just changed a SR20 CVT transmission and now after running the vehicle runs for about 15 mins it just gears down to first gear and sticks there. Already changed the speed sensors and the electric solenoid and still no change. Did a diagnostics today and not getting any reading from the input and output speed sensors but everytime it cools down and starts again it runs good for a 15 mins and then the problem starts again.
Any advice will be greatly appreciated.

Advertisement
User avatar
supercharged turbo
punchin NOS
Posts: 2883
Joined: January 19th, 2011, 6:53 pm
Location: turn around

Re: SR20 CVT Tranny Problem

Postby supercharged turbo » May 11th, 2017, 6:07 pm

Run a transmission cooler

User avatar
lawyer22
Ricer
Posts: 18
Joined: April 9th, 2012, 4:26 pm

Re: SR20 CVT Tranny Problem

Postby lawyer22 » May 11th, 2017, 8:32 pm

It could be the stepup motor on the valve body in the tranny , if you have already change the two sensors.

User avatar
killercow
3NE2NR is my LIFE
Posts: 731
Joined: July 29th, 2010, 6:33 pm
Location: Waze

Re: SR20 CVT Tranny Problem

Postby killercow » May 12th, 2017, 7:21 am

Thanks for the advice. Will try running a cooler first and see what happens.

User avatar
Trendsettermarkyboy
Riding on 13's
Posts: 11
Joined: November 16th, 2012, 3:56 pm

Re: SR20 CVT Tranny Problem

Postby Trendsettermarkyboy » May 12th, 2017, 7:28 am

Where did u get the sensors to buy.. an where is the electric solenoid located on the tranny

User avatar
killercow
3NE2NR is my LIFE
Posts: 731
Joined: July 29th, 2010, 6:33 pm
Location: Waze

Re: SR20 CVT Tranny Problem

Postby killercow » May 12th, 2017, 7:33 am

Well I didn't buy the sensors. I just used the sensors from my old tranny. But I've been told there's a place in Chaguanas that sells the sensors for like $1,500. And the solenoid is located right next to one of the speed sensors at the top of the tranny.

User avatar
Trendsettermarkyboy
Riding on 13's
Posts: 11
Joined: November 16th, 2012, 3:56 pm

Re: SR20 CVT Tranny Problem

Postby Trendsettermarkyboy » May 19th, 2017, 6:18 am

Hey did u gt with the problem

User avatar
killercow
3NE2NR is my LIFE
Posts: 731
Joined: July 29th, 2010, 6:33 pm
Location: Waze

Re: SR20 CVT Tranny Problem

Postby killercow » May 19th, 2017, 7:06 am

Hey man. Na I eh gt with the problem yet. The tranny is overheating. I ran an external cooler (correct size) but the fluid is extremely hot still. Gonna try a flush either today or tomorrow and see if the fluid itself currently is the problem.

Advertisement

Return to “NISSAN”

Who is online

Users browsing this forum: No registered users and 3 guests