TriniTuner.com  |  Latest Event:  

Forums

Almera problem - Often won't rev past 3000 rpm

Sunny to Skyline - SR20, CA18, RB20-26, VG30 etc.

Moderator: 3ne2nr Mods

User avatar
rmlmv
3NE 2NR for life
Posts: 213
Joined: August 29th, 2008, 2:18 pm
Location: Curepe

Almera problem - Often won't rev past 3000 rpm

Postby rmlmv » March 3rd, 2016, 8:40 pm

Hi All,
Looking for advice here please...

My Almera, QG18de is now giving the below problem (see video) where it often won't rev past 3000 rpm. It's not my video but it's the exact symptom. See more details after the video.




Doesn't seem to happen when engine is cold, and doesn't happen all the time, but does happen often. No check engine light. Cam and Crank sensors were changed about a year ago, with brand new sensors. Otherwise the car drives fine.

Recently changed the below to try to fix it, but they didn't work:

1. Oil, Oil Filter, Air Filter, Spark Plugs, Coolant, Fuel injectors.
2. Coolant temperature sensor.
3. All four Ignition Coils.
4. Throttle body with it's TPS and ICV, twice.
5. Mass Air Flow sensor.
6. ECU.

I'm putting off going for a diagnostic as the last time I went, without the check engine light on, there were no error codes, and what the guy told me wasn't the solution with my last problem with the car. I don't want to, yet again throw away $300 to do a diagnostic, when the car is not throwing a code, for a definite solution.

This car is really turning me away from another Nissan in the future.

Positive comments are appreciated.

Advertisement
User avatar
X_Factor
TriniTuner 24-7
Posts: 8879
Joined: April 27th, 2003, 5:54 pm
Location: St. Augustine
Contact:

Re: Almera problem - Often won't rev past 3000 rpm

Postby X_Factor » March 3rd, 2016, 9:09 pm

u should try cam/crank sensors once more
or atleast swap them around as its the same sensor and see what happens

this vehicle isnt in trinidad huh?

User avatar
rmlmv
3NE 2NR for life
Posts: 213
Joined: August 29th, 2008, 2:18 pm
Location: Curepe

Re: Almera problem - Often won't rev past 3000 rpm

Postby rmlmv » March 3rd, 2016, 10:50 pm

Hmm... Ok thanks will definitely try that.

Yes, it's in trinidad. Video is not mine, but it's the exact symptom.

User avatar
rambo88
Street 2NR
Posts: 63
Joined: December 12th, 2012, 9:26 pm

Re: Almera problem - Often won't rev past 3000 rpm

Postby rambo88 » March 4th, 2016, 2:40 am

rmlmv wrote:Hmm... Ok thanks will definitely try that.

Yes, it's in trinidad. Video is not mine, but it's the exact symptom.
my boi had that same problem and he changed everything. D problem was solved after i changed d harness

trini iceman
Trinituner Peong
Posts: 460
Joined: January 12th, 2013, 1:14 pm

Re: Almera problem - Often won't rev past 3000 rpm

Postby trini iceman » March 4th, 2016, 3:33 am

Oh my this sounds interesting. 3981404 whatsapp

User avatar
1UZFE
punchin NOS
Posts: 4966
Joined: May 6th, 2011, 10:55 am

Re: Almera problem - Often won't rev past 3000 rpm

Postby 1UZFE » March 4th, 2016, 5:09 am

Had this problem already. I cant remember if it was d transmission sensor or d speed sensor. I went to Gentons and they diagnosed the problem. I tawt it was d tranny but it was a simple fix.

User avatar
rmlmv
3NE 2NR for life
Posts: 213
Joined: August 29th, 2008, 2:18 pm
Location: Curepe

Re: Almera problem - Often won't rev past 3000 rpm

Postby rmlmv » March 4th, 2016, 3:18 pm

Hmm... Thanks fellas... will look into those next.

User avatar
pjfred
Sweet on this forum
Posts: 346
Joined: February 8th, 2011, 9:18 pm

Re: Almera problem - Often won't rev past 3000 rpm

Postby pjfred » March 4th, 2016, 3:45 pm

Sometimes according to what type of scanner you are using, you will have issues but won't pick up the code. What you need is a good mechanic with experience to know what he is looking for by looking at the data stream generated. I recently came across a qg15 that did something similar and it was the thermal sensor/ circuit faulty. Inspecting the connector revealed sockets that weren't tight and with engine vibration, scanner was not fast enough to read rapid changes plus computer was not capable cuz the frequency was too high. Strange, unbelievable but new connector and bingo! $20 fix after a week of stress.

User avatar
1UZFE
punchin NOS
Posts: 4966
Joined: May 6th, 2011, 10:55 am

Re: Almera problem - Often won't rev past 3000 rpm

Postby 1UZFE » March 4th, 2016, 5:48 pm

Pjfred. U are right. Mine didnt trow any codes. It was d scanner and d experience from d tech at Gentons that helped me out. He gat reading on his scanner n he interpreted it.

User avatar
rmlmv
3NE 2NR for life
Posts: 213
Joined: August 29th, 2008, 2:18 pm
Location: Curepe

Re: Almera problem - Often won't rev past 3000 rpm

Postby rmlmv » April 4th, 2016, 3:20 pm

Just a small update on this. Swapped cam and crank sensors, but same issue remains. Today I was planning to visit the electrician, but I had a few errands to run first. I tried during this time to replicate the problem and the car was just working 100% fine. :roll: Will try again tomorrow, and if it happens, will go to electrician.

RS Tech
Street 2NR
Posts: 55
Joined: July 10th, 2011, 8:52 am

Re: Almera problem - Often won't rev past 3000 rpm

Postby RS Tech » May 7th, 2016, 11:32 am

Did u get tru with your problem? I have had a very similar problem that had me going crazy for at least a month! Turns out it was caused by a stretched timing chain.....sounds weird right? Wattsapp me @ 792-4967

Advertisement

Return to “NISSAN”

Who is online

Users browsing this forum: No registered users and 6 guests