TriniTuner.com  |  Latest Event:  

Forums

WTK: Are Component Crossovers required when connecting to an Amp?

(I.C.E.)In Car Entertainment - Mobile Audio and Video

Moderator: 3ne2nr Mods

User avatar
BlackOps2
3NE 2NR for life
Posts: 104
Joined: October 14th, 2012, 1:55 pm

WTK: Are Component Crossovers required when connecting to an Amp?

Postby BlackOps2 » August 18th, 2017, 3:57 pm

Good day, looked online but got no proper answer really to my question. Reason I asked this is because I currently have a pair of Morel Virtus 6.5" Compenent Speakers in my front doors as well as Morel Tempo in the Rear doors powered by a JL jx400/4D. Purchased the vehicle from the previous owner with with the speakers already installed and I installed the amp by a reputable installer. The Guy proceeded to remove the Crossovers from the Morel Virtus and connected directly to the amp, the front speakers and the component tweeters. When asked why out of curiosity, the answer was that the amp and deck has the necessary crossover settings so it isn't needed

Did This was a few months ago, Now suddenly, both front door morel component speakers stopped playing at the same time, as well as the speakers. Just came home from by another guy who told me the reason they stopped working was because of the removal of the crossovers. I know I'm screwed because of the cost of a pair of those components but I'd really like to know about the Crossovers for my knowledge and if they are/Are not supposed to be installed if an amp is present and the deck has crossover settings. Thanks

Advertisement
kavaninho
Trinituner Peong
Posts: 471
Joined: March 29th, 2008, 8:30 pm
Location: Gasparillo
Contact:

Re: WTK: Are Component Crossovers required when connecting to an Amp?

Postby kavaninho » August 18th, 2017, 4:07 pm

Well from what you said in the the first half I would have trusted that the installer knew what he was doing and actively crossed the system. When the system was altered, did the installer ran all the woofers off 2 channels and all the tweets of the other 2 channels? If not, you were bound to be blown without the passives installed :(

So youre saying both the woofers and tweeters are blown on the frontstage?

User avatar
BlackOps2
3NE 2NR for life
Posts: 104
Joined: October 14th, 2012, 1:55 pm

Re: WTK: Are Component Crossovers required when connecting to an Amp?

Postby BlackOps2 » August 18th, 2017, 8:15 pm

kavaninho wrote:Well from what you said in the the first half I would have trusted that the installer knew what he was doing and actively crossed the system. When the system was altered, did the installer ran all the woofers off 2 channels and all the tweets of the other 2 channels? If not, you were bound to be blown without the passives installed :(

So youre saying both the woofers and tweeters are blown on the frontstage?

Both of them are fried yes

User avatar
nervewrecker
TriniTuner 24-7
Posts: 20356
Joined: July 31st, 2007, 2:27 pm
Location: The world is fl4t

Re: WTK: Are Component Crossovers required when connecting to an Amp?

Postby nervewrecker » August 18th, 2017, 8:21 pm

What deck?

User avatar
nervewrecker
TriniTuner 24-7
Posts: 20356
Joined: July 31st, 2007, 2:27 pm
Location: The world is fl4t

Re: WTK: Are Component Crossovers required when connecting to an Amp?

Postby nervewrecker » August 18th, 2017, 8:21 pm

And yea, sounds like the new installer f**ked you (guy who removed the xovers).

The xovers are passive type crossovers witt set crossover points to low pass the midwoofer and highpass (also attenuate) the tweeters.
If you are removing them and have an active xover like the 80prs has you can use a dedicated channel from an amp for a dedicated driver from the corresponding deck output. With the active setup you can adjust your crossover points, slope and output level to suit you (provided its within acceptable and capable parameters of the drivers).

Long story short, you send bass to your tweeters and fook dem.

Will need more info on the midwoofer

User avatar
racedriverpro
punchin NOS
Posts: 3101
Joined: September 12th, 2012, 1:12 pm

Re: WTK: Are Component Crossovers required when connecting to an Amp?

Postby racedriverpro » August 18th, 2017, 11:22 pm

Pretty much what those guys said...how did the speakers sound? Any mid bass at all when they were working? If not speakers could have been overdriven (too much powah) without u noticing. Removing those crossovers probably just opened the flood Gates of power to those speakers without u noticing due to the crossover adjustments on the deck/amp.

kavaninho
Trinituner Peong
Posts: 471
Joined: March 29th, 2008, 8:30 pm
Location: Gasparillo
Contact:

Re: WTK: Are Component Crossovers required when connecting to an Amp?

Postby kavaninho » August 18th, 2017, 11:24 pm

Strange that the woofer blew too..... Did you test the components to ensure that they bite the dust?

User avatar
BlackOps2
3NE 2NR for life
Posts: 104
Joined: October 14th, 2012, 1:55 pm

Re: WTK: Are Component Crossovers required when connecting to an Amp?

Postby BlackOps2 » August 19th, 2017, 8:13 am

nervewrecker wrote:What deck?

AVH-X2800BS

User avatar
BlackOps2
3NE 2NR for life
Posts: 104
Joined: October 14th, 2012, 1:55 pm

Re: WTK: Are Component Crossovers required when connecting to an Amp?

Postby BlackOps2 » August 19th, 2017, 8:15 am

kavaninho wrote:Strange that the woofer blew too..... Did you test the components to ensure that they bite the dust?

Got them checked yesterday, the woofers are playing but extremely low for some reason,guy who checked the systemsaid they may be partially damaged, but the tweets are completely fried

User avatar
BlackOps2
3NE 2NR for life
Posts: 104
Joined: October 14th, 2012, 1:55 pm

Re: WTK: Are Component Crossovers required when connecting to an Amp?

Postby BlackOps2 » August 19th, 2017, 8:17 am

racedriverpro wrote:Pretty much what those guys said...how did the speakers sound? Any mid bass at all when they were working? If not speakers could have been overdriven (too much powah) without u noticing. Removing those crossovers probably just opened the flood Gates of power to those speakers without u noticing due to the crossover adjustments on the deck/amp.

Was actually getting everything when they were working, I never even play my music above volume 10 as well to say put pressure on them

User avatar
BlackOps2
3NE 2NR for life
Posts: 104
Joined: October 14th, 2012, 1:55 pm

Re: WTK: Are Component Crossovers required when connecting to an Amp?

Postby BlackOps2 » August 19th, 2017, 8:18 am

BlackOps2 wrote:
nervewrecker wrote:What deck?

AVH-X2800BS

What additional info you need on the woofer?

User avatar
racedriverpro
punchin NOS
Posts: 3101
Joined: September 12th, 2012, 1:12 pm

Re: WTK: Are Component Crossovers required when connecting to an Amp?

Postby racedriverpro » August 19th, 2017, 8:20 am

Well we know now that whatever the installer did fcuked up the spkrs. Just don't know what he did exactly.

User avatar
nervewrecker
TriniTuner 24-7
Posts: 20356
Joined: July 31st, 2007, 2:27 pm
Location: The world is fl4t

Re: WTK: Are Component Crossovers required when connecting to an Amp?

Postby nervewrecker » August 19th, 2017, 9:12 am

Is your deck in network mode? Just asking

kavaninho
Trinituner Peong
Posts: 471
Joined: March 29th, 2008, 8:30 pm
Location: Gasparillo
Contact:

Re: WTK: Are Component Crossovers required when connecting to an Amp?

Postby kavaninho » August 19th, 2017, 10:22 am

nervewrecker wrote:Is your deck in network mode? Just asking



this!


And the reason you may have smoked the tweets since you're interested is because you sent an almost fullrange signal to them. The passive xover would have low-passed your woofer and high-passed your tweeter.

Still find it strange the woofer acting up though.

User avatar
X_Factor
TriniTuner 24-7
Posts: 8833
Joined: April 27th, 2003, 5:54 pm
Location: St. Augustine
Contact:

Re: WTK: Are Component Crossovers required when connecting to an Amp?

Postby X_Factor » August 19th, 2017, 10:38 am

you really didnt need the passives since the deck can do 3 way active
its just a matter of once it was set up properly at the time of install

if it was set up improperly and u said it was done a few mths ago did it work fine then?....
was it played the same way throughout and it now gave out?

anything was done to probably cause the deck to reset?
changed or disconnected battery ?

cause honestly if it was initially set up improperly it wont have even lasted your first above average listening level

User avatar
SR
Chief Cook & Instigator
Posts: 13208
Joined: April 7th, 2003, 8:11 pm

Re: WTK: Are Component Crossovers required when connecting to an Amp?

Postby SR » August 19th, 2017, 10:53 am

Your "reputable" installer screwed u over. As well as gain setup seems wrong as well. Volume level10 on a pioneer deck is very soft.

User avatar
nervewrecker
TriniTuner 24-7
Posts: 20356
Joined: July 31st, 2007, 2:27 pm
Location: The world is fl4t

Re: WTK: Are Component Crossovers required when connecting to an Amp?

Postby nervewrecker » August 19th, 2017, 11:11 am

BlackOps2 wrote:
BlackOps2 wrote:
nervewrecker wrote:What deck?

AVH-X2800BS

What additional info you need on the woofer?
I dont understand what you said when you stated that the amp is connected to the front speakers, morel speakers and tweeters. Is everything hooked up together in parallel?

User avatar
nick639v2
Riding on 16's
Posts: 1148
Joined: November 1st, 2016, 9:46 am

WTK: Are Component Crossovers required when connecting to an Amp?

Postby nick639v2 » August 19th, 2017, 1:10 pm

SR wrote:Your "reputable" installer screwed u over. As well as gain setup seems wrong as well. Volume level10 on a pioneer deck is very soft.



I too suspect that op was clipping at very low volumes ....


Rip to some quality equipment there

User avatar
nervewrecker
TriniTuner 24-7
Posts: 20356
Joined: July 31st, 2007, 2:27 pm
Location: The world is fl4t

Re: WTK: Are Component Crossovers required when connecting to an Amp?

Postby nervewrecker » August 19th, 2017, 4:19 pm

I have for sale some elates and a pair of rainbow tweeters if op interested.

User avatar
ruffneck_12
Trying to catch PATCH AND VEGA
Posts: 6018
Joined: May 4th, 2008, 3:29 pm
Location: I doh live no wey
Contact:

Re: WTK: Are Component Crossovers required when connecting to an Amp?

Postby ruffneck_12 » August 20th, 2017, 5:35 pm

Image

HeY guYs Im a RePuTABle InStaLler



Hope you got your money back.

When men accustom hooking up eminence and nb1's yes

Advertisement

Return to “I.C.E. / Car Audio Tech”

Who is online

Users browsing this forum: No registered users and 4 guests