TriniTuner.com  |  Latest Event:  

Forums

NZE121 AC warm on low RPM

It's all about 4AGE, NZE, 3SGTE, 1JZ, 2JZ etc.

Moderator: 3ne2nr Mods

User avatar
simplejack
3NE 2NR for life
Posts: 205
Joined: July 1st, 2013, 9:41 pm

NZE121 AC warm on low RPM

Postby simplejack » May 15th, 2018, 10:34 am

Hey guys

Did some reading on this and they said it could possibly be the fan not cooling the condenser when i'm on a low RPM (in traffic) because once i am driving highway speeds the ac is pretty cold?

Anyone had similar experiences and was able to resolve?

Advertisement
User avatar
PariaMan
Riding on 18's
Posts: 1682
Joined: July 9th, 2010, 10:38 am

Re: NZE121 AC warm on low RPM

Postby PariaMan » May 15th, 2018, 10:43 am

Went to 3 different places. The last guy said it was some clutch was worn . Removed a washer for a 150 and breeze cold again. Also check your cabin filter and spray out your blower

User avatar
simplejack
3NE 2NR for life
Posts: 205
Joined: July 1st, 2013, 9:41 pm

Re: NZE121 AC warm on low RPM

Postby simplejack » May 15th, 2018, 10:57 am

PariaMan wrote:Went to 3 different places. The last guy said it was some clutch was worn . Removed a washer for a 150 and breeze cold again. Also check your cabin filter and spray out your blower


I'm sure if I go alot of AC men would try to chain me up to possibly change compressor. Who was the last guy you checked?

User avatar
PariaMan
Riding on 18's
Posts: 1682
Joined: July 9th, 2010, 10:38 am

Re: NZE121 AC warm on low RPM

Postby PariaMan » May 15th, 2018, 11:04 am

An old guy opposite the unipet gas station in tarcarigua. Same chain up I was getting

User avatar
PariaMan
Riding on 18's
Posts: 1682
Joined: July 9th, 2010, 10:38 am

Re: NZE121 AC warm on low RPM

Postby PariaMan » May 15th, 2018, 11:20 am

But change your filter and spray out your blower too

User avatar
cueball1990
Trinituner Peong
Posts: 442
Joined: March 24th, 2015, 11:32 pm

Re: NZE121 AC warm on low RPM

Postby cueball1990 » May 16th, 2018, 1:44 pm

did they check the ac high and low pressure? system topped up? could possibly be the expansion valve sticking. some usual causes include the condenser fans, clogged drier receiver and a failing compressor hopefully its not that though. Try changing the cabin filter and see if it helps at all.

Advertisement

Return to “TOYOTA”

Who is online

Users browsing this forum: No registered users and 3 guests