TriniTuner.com  |  Latest Event:  

Forums

ALL 4G93T OWNERS - Post your most common problems !!!

Mitsu Lancer, Evo, GSR, MIVEC, 4G**, GDI, Galant, Outlander, L200 Sportero/Triton etc.

Moderator: 3ne2nr Mods

User avatar
BoostJunkieXL
Sweet on this forum
Posts: 330
Joined: August 31st, 2008, 9:39 pm

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby BoostJunkieXL » November 13th, 2015, 3:07 pm

should just do a compression test and check that out ? are there any other areas that can cause this problem ? problem only started couple weeks ago engine had less than 100k when I bought it couple months ago I hope this isn't the case :(

Advertisement
User avatar
747 TECHNOLOGIES
TriniTuner 24-7
Posts: 8240
Joined: April 18th, 2003, 8:47 am
Location: Shaz Auto Repairs & Performance @ Bamboo #2
Contact:

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby 747 TECHNOLOGIES » November 13th, 2015, 6:25 pm

my non gdi 93t had that issue, and was the piston area that holds the rings were damaged

User avatar
Kronik
Shifting into 6th
Posts: 2014
Joined: July 23rd, 2004, 9:37 pm
Location: Central
Contact:

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby Kronik » November 14th, 2015, 8:29 am

Could be your throttle body, because if it works fine on tiptronic and hard acceleration, I doubt is rings. Did you do anything to the car before the problems started

Sent from my SM900 Note 3

User avatar
747 TECHNOLOGIES
TriniTuner 24-7
Posts: 8240
Joined: April 18th, 2003, 8:47 am
Location: Shaz Auto Repairs & Performance @ Bamboo #2
Contact:

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby 747 TECHNOLOGIES » November 14th, 2015, 11:54 am

Ahhhh yes just got done porting my 4g93t head, put in valves and checked for leaks and none :D

Time to head down and get polishing tool now

User avatar
BoostJunkieXL
Sweet on this forum
Posts: 330
Joined: August 31st, 2008, 9:39 pm

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby BoostJunkieXL » November 16th, 2015, 9:33 am

Kronik wrote:Could be your throttle body, because if it works fine on tiptronic and hard acceleration, I doubt is rings. Did you do anything to the car before the problems started

Sent from my SM900 Note 3




didnt do anything just hopped in my car one saturday morning and had the problem :/ ...drove the car friday night and worked fine....tb could probable need cleaning :/ problem got worse over the weekend

User avatar
BoostJunkieXL
Sweet on this forum
Posts: 330
Joined: August 31st, 2008, 9:39 pm

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby BoostJunkieXL » November 16th, 2015, 9:35 am

747 TECHNOLOGIES wrote:my non gdi 93t had that issue, and was the piston area that holds the rings were damaged



i hope thats not the case......this thing gonna make me poor :/

User avatar
747 TECHNOLOGIES
TriniTuner 24-7
Posts: 8240
Joined: April 18th, 2003, 8:47 am
Location: Shaz Auto Repairs & Performance @ Bamboo #2
Contact:

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby 747 TECHNOLOGIES » November 17th, 2015, 7:16 am

Did you get a compression test done?

User avatar
747 TECHNOLOGIES
TriniTuner 24-7
Posts: 8240
Joined: April 18th, 2003, 8:47 am
Location: Shaz Auto Repairs & Performance @ Bamboo #2
Contact:

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby 747 TECHNOLOGIES » November 17th, 2015, 7:17 am

If you in my area, bamboo and wanna pass in my garage, I could also just do a quick run thru and see if might be any other issues

User avatar
BoostJunkieXL
Sweet on this forum
Posts: 330
Joined: August 31st, 2008, 9:39 pm

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby BoostJunkieXL » November 24th, 2015, 2:29 pm

747 TECHNOLOGIES wrote:If you in my area, bamboo and wanna pass in my garage, I could also just do a quick run thru and see if might be any other issues



if i passed during the week you'd be closed...work nah :( ...i can pass on saturday if you're available pm a price and time if you can please.

User avatar
BoostJunkieXL
Sweet on this forum
Posts: 330
Joined: August 31st, 2008, 9:39 pm

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby BoostJunkieXL » November 24th, 2015, 2:32 pm

BoostJunkieXL wrote:
747 TECHNOLOGIES wrote:If you in my area, bamboo and wanna pass in my garage, I could also just do a quick run thru and see if might be any other issues



if i passed during the week you'd be closed...work nah :( ...i can pass on saturday if you're available pm a price and time if you can please.



I also need to do some major suspension work alot or squeaks and knocks so if you have time i'd let you do all that as well. Thanks

User avatar
747 TECHNOLOGIES
TriniTuner 24-7
Posts: 8240
Joined: April 18th, 2003, 8:47 am
Location: Shaz Auto Repairs & Performance @ Bamboo #2
Contact:

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby 747 TECHNOLOGIES » November 24th, 2015, 6:26 pm

My garage is home lol so im available nearly anytime

My cousin is in front of my house same yard and does electrical as well

User avatar
BoostJunkieXL
Sweet on this forum
Posts: 330
Joined: August 31st, 2008, 9:39 pm

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby BoostJunkieXL » November 25th, 2015, 12:57 pm

if i had known that i would've passed yesterday i was in the bamboo area by 5 no traffic...gotta pick up they wifey today tho so friday evening, if you can, let me know ill pass. if its just for you to check it and i can come back another day to fix ill appreciate it.

User avatar
747 TECHNOLOGIES
TriniTuner 24-7
Posts: 8240
Joined: April 18th, 2003, 8:47 am
Location: Shaz Auto Repairs & Performance @ Bamboo #2
Contact:

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby 747 TECHNOLOGIES » December 24th, 2015, 3:16 pm

Needed urgently.....gsr 4g93t stock piston and one rod....

Car down too long and just gonna put the block stock for the time...

If i get one piston alone i might end up buying forged rods one time as im getting a set for a good price....

1988kerry
Riding on 13's
Posts: 2
Joined: November 14th, 2013, 12:45 am

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby 1988kerry » January 29th, 2016, 3:45 pm

Lf 4g93t engine parts from cm5a urgent

User avatar
BoostJunkieXL
Sweet on this forum
Posts: 330
Joined: August 31st, 2008, 9:39 pm

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby BoostJunkieXL » February 3rd, 2016, 9:35 am

good day just need some advice. I saw a DIY thread on tuner regarding cleaning your intake manifold for gdi engines which i followd through also cleaning my tb and injectors one time. car works better however prior to that i've been getting alot of issues regarding power. mainly the car would jerk and buck when trying to change into a gear and an extreme loss of power as well as burning rich and drinking gas like whoaaa...did some checking and found out that the tps could be an issue so i bought one...haven't installed as yet. what im concerned about tho is over the weekend when i was cleaning my intake manifold and tb etc. as i took out the piping leading to the tb i noticed that the butterfly valve was a bit opened. not a slight 10 degree crack or anything like that but like about 30-35 degrees open. padnah of mine who was there said that's how its supposed to be to allow the car to idle so im not sure if that's true or not. i thought its supposed to either be shut or have a slight gap. Any who another "mechanic" said its supposed to be fully shut and that the tps inst allowing that to be happen so it may be faulty..he didn't know i already purchased a tps suspecting it faulty but due to other reasons. since cleaning the throttle body and intake manifold however, the jerking and bucking have become more frequent and more hard than it did before. can anyone shed some light in this ? any help/ advice would be greatly appreciated as the guy who installed the engine has deserted me and im left with a gdi engine and no one to guide in fixing issues just a little help from padnas who have d same engine and advice from every "mechanic" with a lancer. Thanks !!

User avatar
NR8
Riding on 17's
Posts: 1535
Joined: January 14th, 2012, 2:20 pm

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby NR8 » February 3rd, 2016, 9:54 am

^^Can you provide a link to that thread please?

User avatar
BoostJunkieXL
Sweet on this forum
Posts: 330
Joined: August 31st, 2008, 9:39 pm

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby BoostJunkieXL » February 3rd, 2016, 10:51 am

NR8 wrote:^^Can you provide a link to that thread please?



viewtopic.php?f=33&t=453517&hilit=diy

User avatar
NR8
Riding on 17's
Posts: 1535
Joined: January 14th, 2012, 2:20 pm

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby NR8 » February 3rd, 2016, 10:58 am

Much thanks.

trini iceman
Trinituner Peong
Posts: 460
Joined: January 12th, 2013, 1:14 pm

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby trini iceman » February 3rd, 2016, 11:29 am

You need to know exactly what the TPS is telling the computer and causing the transmission to freak out. How's the idle speed?

User avatar
BoostJunkieXL
Sweet on this forum
Posts: 330
Joined: August 31st, 2008, 9:39 pm

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby BoostJunkieXL » February 3rd, 2016, 12:06 pm

in traffic idle speed is around 700 rpm on drive. if i switch to neutral however idle speed jumps to 1000-1200 rpm n slowly dials down to about 900 rpm :/ where or how can i check what the tps is telling the computer to cause the transmission issue ?

trini iceman
Trinituner Peong
Posts: 460
Joined: January 12th, 2013, 1:14 pm

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby trini iceman » February 3rd, 2016, 12:41 pm

Scan tool/scope. Do you have any engine check light?

trini iceman
Trinituner Peong
Posts: 460
Joined: January 12th, 2013, 1:14 pm

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby trini iceman » February 3rd, 2016, 1:12 pm

Dumping fuel and power loss. How's your spark? I overlooked that, sorry. It idles fine? Starts easily?

User avatar
BoostJunkieXL
Sweet on this forum
Posts: 330
Joined: August 31st, 2008, 9:39 pm

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby BoostJunkieXL » February 3rd, 2016, 1:21 pm

starts easy 99% of the times only had a cold start once since i did the conversion and once when i had a radiator leak and the rad was empty. it idles fine most of the times on drive but sometimes it kinda idles rough like it wants to shut off then as it reaches that point the idle raises. my rpm gauge isnt working due to an electrical issue so i cant check it unless i have torque connected. on park it idles like its about to cut off and on neutral it idles at around 1200. changed spark plugs and oil in december and my cel is on because the sensor by the catalytic converter isnt installed as i havent upgraded my piping yet and the orignal piping from the car when it had the 1.3 engine is still on minus a 2.5 axelback dont know if that would contribute to the problem :/ i just wish i could get someone who knows what the eff they doing to check it out but everyone i check so far dunno wtf :/ guy rell stick me with the gdi engine which when me n him were good was working fine till he started ignoring me then cut me off :/ so yeah trying to do things on my own :/

trini iceman
Trinituner Peong
Posts: 460
Joined: January 12th, 2013, 1:14 pm

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby trini iceman » February 3rd, 2016, 1:32 pm

3981404 whatsapp me

User avatar
BoostJunkieXL
Sweet on this forum
Posts: 330
Joined: August 31st, 2008, 9:39 pm

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby BoostJunkieXL » February 3rd, 2016, 2:00 pm

I'll whatapp you when i get home. cant at work :/

User avatar
realjitsu
Riding on 13's
Posts: 1
Joined: September 6th, 2007, 7:28 am
Location: Somewhere in Port of Spain
Contact:

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby realjitsu » February 10th, 2016, 9:03 am

Hey guys, any of you know where I may find the Auto tensioner for the power steering pump/alternator drive belt for cm5a 4g93t?

wanger
Riding on 13's
Posts: 6
Joined: August 20th, 2011, 7:23 am

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby wanger » February 15th, 2016, 11:15 am

Guy can a regular fuel pump provide enough gas for the 4g93t gdi

User avatar
BoostJunkieXL
Sweet on this forum
Posts: 330
Joined: August 31st, 2008, 9:39 pm

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby BoostJunkieXL » February 15th, 2016, 11:55 am

yeah i believe so. the fuel going into the engine is dependent on the high pressure pump up front. u can also put a stainless steel/washable filter up front as the fuel pump in the tank gets clogged/dirty quickly (or maybe its just the crappy fuel i get in central)... i have a walbro tho :/

trini iceman
Trinituner Peong
Posts: 460
Joined: January 12th, 2013, 1:14 pm

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby trini iceman » February 15th, 2016, 3:04 pm

wanger wrote:Guy can a regular fuel pump provide enough gas for the 4g93t gdi

From the tank to the high pressure pump yes. The "low pressure" pump is run @100% so on that side is like 60-100psi while the high pressure side is 500-2900psi but remember if you disconnect the fuel lines from the high pressure pump you have to replace them.

wanger
Riding on 13's
Posts: 6
Joined: August 20th, 2011, 7:23 am

Re: ALL 4G93T OWNERS - Post your most common problems !!!

Postby wanger » February 16th, 2016, 6:53 am

Hear my problem I recently do a conversion to 4g93t gdi now every time I try to accelerate the starves and starts breaking up and backfiring I used the original pump from my car with one return but the engine has to returns so what I did was made a y and run the 2 returns into one but someone told me one return needs a regulator on it to build pressure to the injectors before it is returned is it true

Advertisement

Return to “MITSUBISHI”

Who is online

Users browsing this forum: No registered users and 3 guests