TriniTuner.com  |  Latest Event:  

Forums

4G18 - Stall upon start

Mitsu Lancer, Evo, GSR, MIVEC, 4G**, GDI, Galant, Outlander, L200 Sportero/Triton etc.

Moderator: 3ne2nr Mods

Mic
Ricer
Posts: 26
Joined: February 3rd, 2012, 6:58 pm

4G18 - Stall upon start

Postby Mic » April 21st, 2018, 8:38 pm

Hey guys, thanks for taking the time to help me. So the story starts about 3 weeks ago:

I have a CS2 lancer singapore foreign used import. Car is at about 208,000 KM. About 3 weeks ago the car started hestiating and misfiring one day when the gas tank was about less than 1/5 , took it to the mechanic, said it was coil pack. Changed both coil packs and spark plugs and serviced throttle body with spray. Car started running a little better.. But when you accelerate from stop its sluggish and hestitating/misfiring. When it picks up speed it works good but then starts to surge and buck randomly. So did some research and online said it could be the fuel pump.

So today I changed the fuel pump, took off negative pole from battery, replaced the fuel pump with an aftermarket one, and put it back in. Put on the negative pole. Tried to start the car, it started, idled for like 10 seconds (RPM when to 1000) then it started dropping and cut off. The entire time you can hear the fuel pump running. When the car idles for those 10 secs, if u mash the gas pedal, the car cuts off.

Checking the front of the car, you getting gas to the intake line to the fuel rail, injectors pulsing, and you getting spark. But the car cuts off after 10 seconds of idling. Another thing I noticed, when you turn the key to the on position, the fuel pump doesnt prime and send out fuel. Only time it sends out fuel is when the engine is cranking or car is idling for those 10 seconds.

Any advice is much appreciated. Tried another Camshaft sensor but same problem. Mechanic tried diagnostic tool and no errors showing up. Or if anyone is a mechanic and could come home by me and take the job to fix this without killing me with price, inbox me

Thanks Fellas..

Advertisement
Advertisement

Return to “MITSUBISHI”

Who is online

Users browsing this forum: No registered users and 3 guests