TriniTuner.com  |  Latest Event:  

Forums

4g93t gdi running rich

Mitsu Lancer, Evo, GSR, MIVEC, 4G**, GDI, Galant, Outlander, L200 Sportero/Triton etc.

Moderator: 3ne2nr Mods

ray019
Ricer
Posts: 29
Joined: October 13th, 2010, 6:15 pm

4g93t gdi running rich

Postby ray019 » January 13th, 2019, 8:15 pm

Have a 4g93t gdi in my car lancer but it's running extremely rich wide band reads 9.8 and below, this causes my spark plugs to foul up so I have to change plugs every month, there's no boost leak, did an I jector clean and same issue, is there any way to reduce the fuel going into the engine? Or would a remap of the ecu help?

Advertisement
User avatar
xtech
30 pounds of Boost
Posts: 2671
Joined: March 15th, 2006, 2:01 pm
Contact:

Re: 4g93t gdi running rich

Postby xtech » January 14th, 2019, 8:19 am

Either your pumps internal fuel pressure regulator was tampered with or Your injectors are electrically damaged. Maybe by running bad voltage through them when cleaning.

ray019
Ricer
Posts: 29
Joined: October 13th, 2010, 6:15 pm

Re: 4g93t gdi running rich

Postby ray019 » January 14th, 2019, 8:55 am

well i changed the GDI pump 3 times and same issue, i think i'll change the injectors next and see if it helps

nissan4life
Chronic TriniTuner
Posts: 503
Joined: April 10th, 2011, 1:53 pm
Location: 3NE2NR is my LIFE

Re: 4g93t gdi running rich

Postby nissan4life » January 15th, 2019, 11:11 am

I had an issue on 4g15 running rich and it ended up being O2 sensor was bad and giving incorrect readings to ecu
look at the other components that associate with combustion.
Check air filter/maf sensor as well,wont hurt to start ruling out simple solutions first

Advertisement

Return to “MITSUBISHI”

Who is online

Users browsing this forum: No registered users and 3 guests