TriniTuner.com  |  Latest Event:  

Forums

The Official CS Lancer Thread!

Mitsu Lancer, Evo, GSR, MIVEC, 4G**, GDI, Galant, Outlander, L200 Sportero/Triton etc.

Moderator: 3ne2nr Mods

User avatar
Biggs3ne
3NE2NR is my LIFE
Posts: 814
Joined: May 14th, 2008, 7:02 am
Location: Running the Rat Race

Re: CS Lancer!

Postby Biggs3ne » April 17th, 2012, 11:12 am

^^^It's a new battery dude, not even a month old as yet. Volt Meter reads 14.3V as well. I'll probably check all the cells in the battery for bubbles I guess.

Any other suggestions????

Advertisement
User avatar
idlemind
punchin NOS
Posts: 3328
Joined: August 15th, 2005, 9:22 am
Location: (-(     )+)

Re: CS Lancer!

Postby idlemind » April 17th, 2012, 2:37 pm

BrotherHood wrote:idle, was directly behind you for about 10 seconds this afternoon on the Beetham Highway. I'm sure you saw a blue/purple CS behind you at some point.


Yea I vaguely remember a blue/purple CS...was on a beat yesterday yes.

User avatar
BrotherHood
TriniTuner 24-7
Posts: 8232
Joined: October 20th, 2010, 2:41 pm
Location: Bringing HID & LED to a location near you! 355-3165. 704-5442 (WhatsApp).

Re: CS Lancer!

Postby BrotherHood » April 17th, 2012, 3:31 pm

idlemind wrote:
BrotherHood wrote:idle, was directly behind you for about 10 seconds this afternoon on the Beetham Highway. I'm sure you saw a blue/purple CS behind you at some point.


Yea I vaguely remember a blue/purple CS...was on a beat yesterday yes.


yea you was driving like you was on a beat :lol:

User avatar
turbo_beast369
Riding on 18's
Posts: 1638
Joined: January 20th, 2006, 3:41 pm
Location: Sando

Re: CS Lancer!

Postby turbo_beast369 » April 17th, 2012, 4:19 pm

venum wrote:anyone ever changed the seals in the brake system - the master cylinder etc :?:

turbo u did this :?:

where did you get teh kit :?:


bought OEM caliper seal kits, never interfered with the master cylinder...I got my seals from www.oemmitsubishiparts.com or u can also try www.mitsubishiparts.net

u want a part #?

User avatar
BrotherHood
TriniTuner 24-7
Posts: 8232
Joined: October 20th, 2010, 2:41 pm
Location: Bringing HID & LED to a location near you! 355-3165. 704-5442 (WhatsApp).

Re: CS Lancer!

Postby BrotherHood » April 17th, 2012, 11:32 pm

BrotherHood wrote:Fellas, my car seat stuck in one position. The back rest moves but the entire seat does not slide foward nor backward. I got the car this way. It's ok to sit in but it's beginning to become a nuisance. How can I solve this????
Some good old WD40?

User avatar
EXODUS
punchin NOS
Posts: 3241
Joined: May 8th, 2011, 5:17 pm
Location: unknown

Re: CS Lancer!

Postby EXODUS » April 18th, 2012, 12:13 am

wd40 eh go do much...sounds like sumtins up with ur rail. u may hafta unbolt n flip over to investigate. tedious task if i may...

User avatar
Biggs3ne
3NE2NR is my LIFE
Posts: 814
Joined: May 14th, 2008, 7:02 am
Location: Running the Rat Race

Re: CS Lancer!

Postby Biggs3ne » April 18th, 2012, 1:23 pm

geometron wrote:wd40 eh go do much...sounds like sumtins up with ur rail. u may hafta unbolt n flip over to investigate. tedious task if i may...


Actually the WD-40 did help the sensor. I want to change the gas filter before I even think about interefering with the fuel rail. Thanks for the suggestion though.

BTW where is my gas filter located? I have the 2002 CS3. I checked under my hood and could not locate it, so I assumed that it is the tank. I called a parts place asking if they had any gas filters and when we went into which vehicle I want it for and what not the dude told me that it is under the hood and not the bonnet. He said somewhere on the firewall. Can anyone clear this up and state correctly where my fuel filter is. Sorry if I sounding like a novice, but I would really appreciate this information.

User avatar
EXODUS
punchin NOS
Posts: 3241
Joined: May 8th, 2011, 5:17 pm
Location: unknown

Re: CS Lancer!

Postby EXODUS » April 18th, 2012, 5:22 pm

oh no pal, i was referring to brotherhood there. :D

as opposed to ur prob, yess the MAF sensor and IACV has to be opened and cleaned...wd 40 aint gonna do anything in the long run, jus cause more muck n dust to adhere to the unit. i hadda service my own as we speak cus as soon as i mash gas and let off n press brakes sometimes, the car cuts off or rough idles. so chek tha MAF!

User avatar
EXODUS
punchin NOS
Posts: 3241
Joined: May 8th, 2011, 5:17 pm
Location: unknown

Re: CS Lancer!

Postby EXODUS » April 18th, 2012, 5:24 pm

Biggs3ne wrote:
geometron wrote:wd40 eh go do much...sounds like sumtins up with ur rail. u may hafta unbolt n flip over to investigate. tedious task if i may...


Actually the WD-40 did help the sensor. I want to change the gas filter before I even think about interefering with the fuel rail. Thanks for the suggestion though.

BTW where is my gas filter located? I have the 2002 CS3. I checked under my hood and could not locate it, so I assumed that it is the tank. I called a parts place asking if they had any gas filters and when we went into which vehicle I want it for and what not the dude told me that it is under the hood and not the bonnet. He said somewhere on the firewall. Can anyone clear this up and state correctly where my fuel filter is. Sorry if I sounding like a novice, but I would really appreciate this information.


explain this? lolol.

anyhow, its located under ur back seat where ur pump is. never saw it being changed but my mech says u hadda unhinge the back seats and u'd see the gas tank opening and pump placement. kinda whitish plastic not so?

User avatar
mety57
Chronic TriniTuner
Posts: 638
Joined: January 30th, 2007, 11:43 pm
Location: arouca
Contact:

Re: CS Lancer!

Postby mety57 » April 18th, 2012, 8:39 pm

ok allyuh fellas the convo .......tell meh how the fit looking
csk2 lancer.jpg

csk lancer.jpg

raybic
3NE 2NR for life
Posts: 228
Joined: March 30th, 2010, 7:02 am

Re: CS Lancer!

Postby raybic » April 18th, 2012, 9:53 pm

mety57 , 4g15 fit comfortable there.

User avatar
BrotherHood
TriniTuner 24-7
Posts: 8232
Joined: October 20th, 2010, 2:41 pm
Location: Bringing HID & LED to a location near you! 355-3165. 704-5442 (WhatsApp).

Re: CS Lancer!

Postby BrotherHood » April 18th, 2012, 10:52 pm

yeah mety, lovely fit.

User avatar
Biggs3ne
3NE2NR is my LIFE
Posts: 814
Joined: May 14th, 2008, 7:02 am
Location: Running the Rat Race

Re: CS Lancer!

Postby Biggs3ne » April 19th, 2012, 5:24 am

geometron wrote:
Biggs3ne wrote:
geometron wrote:wd40 eh go do much...sounds like sumtins up with ur rail. u may hafta unbolt n flip over to investigate. tedious task if i may...


the dude told me that it is under the hood and not the bonnet. He said somewhere on the firewall.


I meant to say under the bonnet and not in the gas tank GEO. my bad :oops: was typing a bit fast there...Anyways well it's good to know that I was initially correct and not going blind or something. As for the Maf sensor I think I will swap it out with the one on the spare TB i have in my trunk. Thanks for the feedback bro.

Mety that engine looks really nice in ur ride. I hope that you finally get the opportunity to enjoy it and never ever use that Electrician again.

User avatar
mety57
Chronic TriniTuner
Posts: 638
Joined: January 30th, 2007, 11:43 pm
Location: arouca
Contact:

Re: CS Lancer!

Postby mety57 » April 19th, 2012, 9:44 am

yeah man fellas thks and it woking nice jus need a lil cleaning now

User avatar
TeamH2O
TriniTuner 24-7
Posts: 8240
Joined: April 18th, 2003, 8:47 am
Location: Shaz Auto Repairs & Performance @ Bamboo #2
Contact:

Re: CS Lancer!

Postby TeamH2O » April 19th, 2012, 8:14 pm

ANyone know where i can get two evo 7/8/9 back doors? They are all the same except for interior.

anthonyanthony
Chronic TriniTuner
Posts: 559
Joined: September 30th, 2007, 4:03 pm

Re: CS Lancer!

Postby anthonyanthony » April 19th, 2012, 9:01 pm

People , a friend of mine has a RORO CS3 lancer, 4g18 engine with cvt.
Problem is with ac off both radiator and ac fan comes on and runs.
This happens when engine is cold or hot.
AC switch works , not sticking ie led indicator comes on when ac is on ans off when ac switched off.
Also no check engine light displayed to suggest problem with sensors.
Suggestions ?

User avatar
Biggs3ne
3NE2NR is my LIFE
Posts: 814
Joined: May 14th, 2008, 7:02 am
Location: Running the Rat Race

Re: CS Lancer!

Postby Biggs3ne » April 19th, 2012, 9:55 pm

^^^Fan control module may need replacing. If the fans come on at ignition then the fan control module definitely needs replacing. I replaced mine in January. PM W2J or buy it off EBAY

User avatar
TeamH2O
TriniTuner 24-7
Posts: 8240
Joined: April 18th, 2003, 8:47 am
Location: Shaz Auto Repairs & Performance @ Bamboo #2
Contact:

Re: CS Lancer!

Postby TeamH2O » April 19th, 2012, 10:50 pm

Image
Last edited by TeamH2O on April 19th, 2012, 11:56 pm, edited 1 time in total.

User avatar
EXODUS
punchin NOS
Posts: 3241
Joined: May 8th, 2011, 5:17 pm
Location: unknown

Re: CS Lancer!

Postby EXODUS » April 19th, 2012, 11:36 pm

^^^ wham there son? lolol.

User avatar
venum
3NE2NR Diesel Boyz
Posts: 5936
Joined: May 7th, 2004, 3:19 pm
Location: San Fernando

Re: CS Lancer!

Postby venum » April 19th, 2012, 11:40 pm

the 4G18 does not have a MAF sensor

it has a MAP sensor

the fuel filter is located on the fuel pump

which is inside teh gas tank

remove back seat

Image

remove cover

Image

Image

Image

raybic
3NE 2NR for life
Posts: 228
Joined: March 30th, 2010, 7:02 am

Re: CS Lancer!

Postby raybic » April 20th, 2012, 6:56 am

becareful ehh bro there is a clip with a seal on the the bracket that holds the pressure in the lines for ur car to be able to start with one crank inside the tank, if u cleanin it take ur time.

User avatar
Biggs3ne
3NE2NR is my LIFE
Posts: 814
Joined: May 14th, 2008, 7:02 am
Location: Running the Rat Race

Re: CS Lancer!

Postby Biggs3ne » April 20th, 2012, 8:12 am

raybic wrote:becareful ehh bro there is a clip with a seal on the the bracket that holds the pressure in the lines for ur car to be able to start with one crank inside the tank, if u cleanin it take ur time.


I want to change the filter completely. Not too sure as yet if I want to attempt this on my own or get it done by a mechanic. I will do some more research before I decide.

Thanks for the info and pics Venum.

Well I upgraded the grounding wires in my car with the help of my neighbour last night. Bought 5 yards of 4 guage wire and 8 ring terminals. Cost just $144 in total. Grounding points were: Battery to Chasis, Battery to Engine, Battery to Alternator and Engine to Chassis.

Results:

1. Idle no longer drops when I turn on Headlights and Fogs.
2. Idle no longer drops when I turn AC on.
3. Throttle response has significantly improved.
4. All Lights appear much Brighter especially my Headlights.
5. Started the car this morning and rough idling has significantly improved.

This is a great lil mod for anyone else to do. Cheap and will improve the electrical functioning of the vehicle.

The next thing I want to do is get my 100A alternator fixed and swap it back into the car, and definitely want to change the fuel filter.

I am hoping that when all this is done my rough idle at start up will be completely eliminated.

User avatar
ZeroOne
12 pounds of Boost
Posts: 2242
Joined: August 5th, 2008, 4:10 pm

Re: CS Lancer!

Postby ZeroOne » April 20th, 2012, 8:29 am

pics please

User avatar
Biggs3ne
3NE2NR is my LIFE
Posts: 814
Joined: May 14th, 2008, 7:02 am
Location: Running the Rat Race

Re: CS Lancer!

Postby Biggs3ne » April 20th, 2012, 8:37 am

^^Will post up pics sometime this weekend.

User avatar
genghis
3NE 2NR for life
Posts: 201
Joined: November 2nd, 2005, 12:31 pm

Re: CS Lancer!

Postby genghis » April 20th, 2012, 11:06 am

viewtopic.php?f=6&t=433715

if anyone interested.

User avatar
idlemind
punchin NOS
Posts: 3328
Joined: August 15th, 2005, 9:22 am
Location: (-(     )+)

Re: CS Lancer!

Postby idlemind » April 20th, 2012, 3:50 pm

Running a grounding kit is something I always wanted to do.
Post some pics Biggs hopefully showing where each pt was terminated.

User avatar
BrotherHood
TriniTuner 24-7
Posts: 8232
Joined: October 20th, 2010, 2:41 pm
Location: Bringing HID & LED to a location near you! 355-3165. 704-5442 (WhatsApp).

Re: CS Lancer!

Postby BrotherHood » April 20th, 2012, 4:06 pm

Nice work Biggs

User avatar
thatguy3832
3NE 2NR for life
Posts: 230
Joined: June 23rd, 2009, 11:24 pm
Location: Home
Contact:

Re: CS Lancer!

Postby thatguy3832 » April 21st, 2012, 1:21 am

fellas i seeing some problems here well not problems so much but concern. since i got my lancer every time rain fall and i have the car running is one set ah smoke coming off the hood. yesterday is embarrassment when i gone to pick up my son ah parent came up to the glass and telling me like my car on fire with the amount of smoke. wtf going on?
besides that looking for some drop down back seats in grey and a front cut from a cs5 with the factory installed dvd/navi

User avatar
Ted_v2
TriniTuner 24-7
Posts: 10904
Joined: March 30th, 2010, 8:58 pm

Re: CS Lancer!

Postby Ted_v2 » April 21st, 2012, 5:07 am

thatguy3832 wrote:fellas i seeing some problems here well not problems so much but concern. since i got my lancer every time rain fall and i have the car running is one set ah smoke coming off the hood. yesterday is embarrassment when i gone to pick up my son ah parent came up to the glass and telling me like my car on fire with the amount of smoke. wtf going on?
besides that looking for some drop down back seats in grey and a front cut from a cs5 with the factory installed dvd/navi


smoke?like oil smoke or water vapor?

User avatar
thatguy3832
3NE 2NR for life
Posts: 230
Joined: June 23rd, 2009, 11:24 pm
Location: Home
Contact:

Re: CS Lancer!

Postby thatguy3832 » April 21st, 2012, 7:39 am

heavy vapor

Advertisement

Return to “MITSUBISHI”

Who is online

Users browsing this forum: No registered users and 1 guest