TriniTuner.com  |  Latest Event:  

Forums

Underboosting Engine Shut down

Fuji Heavy Industry tech talk - STi, WRX, Forester etc.

Moderator: 3ne2nr Mods

User avatar
Redeyeblueeye
Street 2NR
Posts: 54
Joined: December 11th, 2007, 6:12 am

Underboosting Engine Shut down

Postby Redeyeblueeye » March 10th, 2008, 3:36 pm

Will underboosting or partial boost caused by possibly bad bearings or whatever in the turbo or even total turbo failure lead to the car shutting down by safeguarding ECU shut down?

Advertisement
User avatar
flatline
3NE 2NR Spannerator
Posts: 2387
Joined: May 1st, 2004, 2:08 pm
Location: cd /pub | more beer

Postby flatline » March 10th, 2008, 4:23 pm

how do you know it's bad turbo bearings? Are you getting shaft play/noises? Is it a totally stock setup/original turbo and manifold? Could be loose vacuum hoses or blown turbo gasket causing the low boost, if you want to check for other things. As for scooby failsafe measures, i can't answer that.

User avatar
Alpha_2nr
punchin NOS
Posts: 3781
Joined: August 17th, 2005, 9:12 pm

Postby Alpha_2nr » March 11th, 2008, 12:51 pm

^^Ditto on flatline's post.

Did you check your turbo to ensure it's bad?

Is there shaft play?

Deposits/coking on blades/inlet?

Smoking turbo?

Excessive oil loss?

User avatar
Redeyeblueeye
Street 2NR
Posts: 54
Joined: December 11th, 2007, 6:12 am

Postby Redeyeblueeye » March 13th, 2008, 4:11 am

Knight1 wrote:^^Ditto on flatline's post.

Did you check your turbo to ensure it's bad?

Is there shaft play?

Deposits/coking on blades/inlet?

Smoking turbo?

Excessive oil loss?


Knight1 remember all this right?

http://forums.trinituner.com/forums/vie ... p?t=164088

Well...
1. the Mech said the Turbo is fine and the car is not pinging but its burning oil.

2. The boost cutting to 7psi like a safe mode like if the car was knocking ...ODB2 shows no knock...AF is rich

3. Bypassed Boost control solenoid(BCS) no problems...Turbo generating 17psi on the Dyno...hook up back the BCS...stayed at 7psi on this run.

Hooked up another BCS from another working car...boost runs fine in 3rd gear at 14 psi then back down to 7psi in 4th. Then it stayed in the subsequent dyno run at 7psi...

i.e.
Its appeared not to be the BCS yet for some reason its getting a signal from the ECU to limit the boost...

My Mech's solution...manual bypass using a Manual boost controller and set it to peak at 14psi and hold at 12psi...


My Views:
This is allowing me boost now
But this did not solve my boost problem...it bypassed it (literally)

My new questions:
1. What ur views as to whats really going on here?
2. Whats ur solution...is this manual BC the solution or should I look to put in back the BCS and look to flash the ECU?
3. What are the implications of the this steady boost on my current map?
4. I risk damaging my engine due to no feedback loop to cut boost for knock...how much knock will do damage...

riderz
3NE 2NR for life
Posts: 167
Joined: October 9th, 2005, 4:19 pm
Location: Trinidad and Tobago
Contact:

Postby riderz » March 13th, 2008, 7:26 am

oh hell, this is typical of IAM dropping below 4. Listen an obdII reader would not pick up knock at this point because your IAM has dropped so low to prevent knock. not to mention once you go that low you switch to a very very rich fuel map. You car is fine. It need some maintainence and tuning for local gas. DO NOT BYPASS THE STOCK BCS you will make the matter worst.

User avatar
Alpha_2nr
punchin NOS
Posts: 3781
Joined: August 17th, 2005, 9:12 pm

Postby Alpha_2nr » March 13th, 2008, 9:43 am

Its appeared not to be the BCS yet for some reason its getting a signal from the ECU to limit the boost...


Your car is detecting knock it looks like.

1. What ur views as to whats really going on here?
2. Whats ur solution...is this manual BC the solution or should I look to put in back the BCS and look to flash the ECU?
3. What are the implications of the this steady boost on my current map?
4. I risk damaging my engine due to no feedback loop to cut boost for knock...how much knock will do damage...


How does your mech know your car isn't pinging? U say he connected to the OBD port and saw no knock? How did he do that?

It sounds like your car is picking up knock correction somewhere...hence the reason that your boost is being cutback (kinda like the failsafe mode).

Answers as follows:

2) Put in stock BCS as ^^^was said before. Get it checked by an ECU tuner locally (gave u details already as per your request......check PM). If your car's log show NO knock correction...time to change mechanics.

3) Steady boost = bad juju for your engine. You can "overboost" on partial throttle, and run the risk of running your engine too lean. The stock BCS adjust boosts on the conditions the engine is seeing like knock, load, throttle position, etc.

4)U answered your own question. NO feedback loop = not good. The extent of knock will determine how much damage. The question is...WHY is it knocking so much.

riderz
3NE 2NR for life
Posts: 167
Joined: October 9th, 2005, 4:19 pm
Location: Trinidad and Tobago
Contact:

Postby riderz » April 20th, 2008, 9:41 am

This wasnt a knock issue (even though the car was knocking), the previous mechanic pulled out the injector pill from the wastegate vacuum hoses. That was sorted out. Good to go now.

User avatar
DavetoExtreme
3NE 2NR for life
Posts: 163
Joined: February 1st, 2005, 12:35 am
Location: North
Contact:

Postby DavetoExtreme » April 20th, 2008, 1:57 pm

riderz wrote:This wasnt a knock issue (even though the car was knocking), the previous mechanic pulled out the injector pill from the wastegate vacuum hoses. That was sorted out. Good to go now.



^^^
A missing injector pill was causing all this? :shock:

riderz
3NE 2NR for life
Posts: 167
Joined: October 9th, 2005, 4:19 pm
Location: Trinidad and Tobago
Contact:

Postby riderz » April 20th, 2008, 2:23 pm

yep.

Not the knock, just the underboosting. Without the pill the Wastegate would not regulate and the car would not past 7psi

User avatar
Redeyeblueeye
Street 2NR
Posts: 54
Joined: December 11th, 2007, 6:12 am

Postby Redeyeblueeye » April 20th, 2008, 8:25 pm

riderz wrote:yep.

Not the knock, just the underboosting. Without the pill the Wastegate would not regulate and the car would not past 7psi



Small correction Riderz...you had it mixed up in the chronology of the events a little...

But yes the knock was retarding IAMs that much to switch to the Hi DET safe map but also before the pill was removed as well...
That is to say the car was knocking badly...
After, the pill was removed in attempt to regain boost to 16 psi through the use of manual boost control. Then I was left with 'dumb' manual mechanical boost...(due to the manual boost control which lead to whatever the dial was adjusted to...i.e the car was adjusted back to 16psi but because it still knocked ...yes it would have then gone right back to 7psi ... that if is it was allowed to...lol :wink: through feedback or the BCS but it didn't...cause' it couldn't)

But all in all of this chronology really not that important admittedly...whole thing is knock is bad bad bad...and fix it asap
but I thought I'd mention it all as I saw the post... :P

User avatar
JWT
Trying to catch PATCH AND VEGA
Posts: 6653
Joined: April 20th, 2003, 12:33 am
Location: making money
Contact:

Postby JWT » April 20th, 2008, 10:10 pm

so i am hoping the car is sorted out

riderz
3NE 2NR for life
Posts: 167
Joined: October 9th, 2005, 4:19 pm
Location: Trinidad and Tobago
Contact:

Postby riderz » April 21st, 2008, 10:52 am

yeah it sorted.

User avatar
Alpha_2nr
punchin NOS
Posts: 3781
Joined: August 17th, 2005, 9:12 pm

Postby Alpha_2nr » April 21st, 2008, 11:28 am

Small correction Riderz...you had it mixed up in the chronology of the events a little...

But yes the knock was retarding IAMs that much to switch to the Hi DET safe map but also before the pill was removed as well...
That is to say the car was knocking badly...

After, the pill was removed in attempt to regain boost to 16 psi through the use of manual boost control. Then I was left with 'dumb' manual mechanical boost...(due to the manual boost control which lead to whatever the dial was adjusted to...i.e the car was adjusted back to 16psi but because it still knocked ...yes it would have then gone right back to 7psi ... that if is it was allowed to...lol through feedback or the BCS but it didn't...cause' it couldn't)


Ahhh so I was right. The car was pulling timing even before you had done the MBC install.

Sceneeeee...hopefully the diagram I provided you with would help you better understand where the restrictor pill is.

8)

riderz
3NE 2NR for life
Posts: 167
Joined: October 9th, 2005, 4:19 pm
Location: Trinidad and Tobago
Contact:

Postby riderz » April 21st, 2008, 11:54 pm

Yep it seemed that when the IAM dropped (because of knock detected) the mechanic tried to troubleshoot as though it was a mechanical issue, not a ECU controlled failsafe. As such he removed the injector pill, install MBC, did some other costly stuff and still didnt work.

All that was corrected and the IAM went immediately to 16. Still some knock so that is being corrected now.

Whenever a WRX, or STi just starts spooling 7 - 9 psi for no reason, most of the time its because the IAM dropped. That happens when the knock count is high. Boost is disabled to run safe.

If you remove the injector pill out of the T connector the car would only run at wastegate boost (7-9psi) not the stock boost levels (WRX 13-14psi, STi 18-20psi)

Advertisement

Return to “SUBARU”

Who is online

Users browsing this forum: No registered users and 6 guests