TriniTuner.com  |  Latest Event:  

Forums

Subaru legacy not starting after engine change

Fuji Heavy Industry tech talk - STi, WRX, Forester etc.

Moderator: 3ne2nr Mods

User avatar
striver
Street 2NR
Posts: 98
Joined: April 3rd, 2013, 6:46 pm

Subaru legacy not starting after engine change

Postby striver » October 13th, 2017, 7:00 pm

Hello.i have a legacy bh5. Recently bought it with an overheated engine.

Car has an ej20 engine non turbo single cam

Today i installed a head and block of the same. All connectors, sensors same.

Mounted up and trying to start ... tumbling and sometimes want to start but not doin so.

Getting fuel. Spark. Injector pulse etc

All grounds are back in place.

Had an alarm guy came and checked the immobilizer and he says its good.

Have not checked timing as yet

The foreign used engine had an egr tube which would have go into the intake manifold.

My enginw dont have that so i blanked it off on the block.

Dont knw if this is causing a problem

Advertisement
User avatar
striver
Street 2NR
Posts: 98
Joined: April 3rd, 2013, 6:46 pm

Re: Subaru legacy not starting after engine change

Postby striver » October 13th, 2017, 7:03 pm

Have not checked compression as well

Any one knows the compression stats for this engine

User avatar
1.6 TURBO
3NE 2NR for life
Posts: 127
Joined: July 11th, 2003, 3:19 pm

Re: Subaru legacy not starting after engine change

Postby 1.6 TURBO » October 20th, 2017, 9:09 am

Had the same problem with an engine rebuild. It just would not start and giving you the false hope it would start by almost starting. Problem was the spark plugs were wet from so much tumbling. Try new dry spark plugs. I remember my mechanic doing an ej16 engine change out on a TS at one time and he had to reuse something from the old engine to do with timing. Will call him later and clarify.

GTR Fever
3NE 2NR Power Seller
Posts: 277
Joined: August 14th, 2011, 7:42 am

Re: Subaru legacy not starting after engine change

Postby GTR Fever » October 20th, 2017, 2:41 pm

Call the guys at CSM, 689-2663

User avatar
striver
Street 2NR
Posts: 98
Joined: April 3rd, 2013, 6:46 pm

Re: Subaru legacy not starting after engine change

Postby striver » October 26th, 2017, 1:34 pm

Update

Did a compression test

# 2 and 4 cylinders have low compression. Was under warranty, so i got another.this new 1 started up perfectly.

User avatar
striver
Street 2NR
Posts: 98
Joined: April 3rd, 2013, 6:46 pm

Re: Subaru legacy not starting after engine change

Postby striver » October 26th, 2017, 1:36 pm

Now is on to suspension repairs

Need to get complete cradle bushings. Big an small. Balljoints

Stabalizer bar link an rubbers

Where can i get original subaru parts besides massy

User avatar
racedriverpro
punchin NOS
Posts: 3190
Joined: September 12th, 2012, 1:12 pm

Re: Subaru legacy not starting after engine change

Postby racedriverpro » October 26th, 2017, 5:53 pm

striver wrote:Now is on to suspension repairs

Need to get complete cradle bushings. Big an small. Balljoints

Stabalizer bar link an rubbers

Where can i get original subaru parts besides massy
Try Dave Adah or AWD Motorsports

User avatar
racedriverpro
punchin NOS
Posts: 3190
Joined: September 12th, 2012, 1:12 pm

Re: Subaru legacy not starting after engine change

Postby racedriverpro » October 26th, 2017, 5:57 pm

striver wrote:Now is on to suspension repairs

Need to get complete cradle bushings. Big an small. Balljoints

Stabalizer bar link an rubbers

Where can i get original subaru parts besides massy
Also I heard bh and bl5 rear suspension is the same.

User avatar
striver
Street 2NR
Posts: 98
Joined: April 3rd, 2013, 6:46 pm

Re: Subaru legacy not starting after engine change

Postby striver » October 30th, 2017, 11:44 am

Nice

Update... this new engine is burning oil

Lots of blue smoke

Have to take out an replace again

Having gotten the car runninh with this engine is only i noticed the tranny is on the way out

What are my options as of now ?

1. Should i replace engine an tranny with a newer type subaru bl5 perhaps

2. If i do this swap do i have to change diff as well to match this new setup

3. Should i keep replacing engines till i find a good 1

4. Should i try a diff tranny . Which i know will be diff as the ratios of the tranny and my diff will be off

5. Should i rebuild the tranny. Problem is finding a kit for this tranny..... TZ1A4Z

User avatar
striver
Street 2NR
Posts: 98
Joined: April 3rd, 2013, 6:46 pm

Re: Subaru legacy not starting after engine change

Postby striver » October 30th, 2017, 11:46 am

I do all the mechanical works my self

This car is a project car for.me

I have always wanted a bh5 subaru wagon

Got this at a good price

Car is currently blue

Love it in the subaru white with subaru gold rims

And of course i like it non turbo

User avatar
TheBoostLord
3NE2NR is my LIFE
Posts: 887
Joined: January 16th, 2006, 1:51 pm
Location: 4th Ave & 5th St. Barataria

Re: Subaru legacy not starting after engine change

Postby TheBoostLord » October 30th, 2017, 2:31 pm

Doing a rebuild on a non turbo engine is significantly cheaper than the turbo stuff so if you are tired with the worn engine that can be a good option for a fresh start. I dont believe the newer trans will work as the connectors/tcu most likely are different, Unless you want to undergo that huge project. Once u get a replacement with the same ratio there is no need to change the diff.

User avatar
striver
Street 2NR
Posts: 98
Joined: April 3rd, 2013, 6:46 pm

Re: Subaru legacy not starting after engine change

Postby striver » November 16th, 2017, 12:58 pm

Update

Replaced head gasket

Engine is starting. Temp is good

Have lots more to do

It idles fast

Tranny has hard shift from neutral to drive

Entire suspension has to do ova

Its a project car

JamieConway88
Riding on 13's
Posts: 5
Joined: January 16th, 2018, 11:03 pm

Re: Subaru legacy not starting after engine change

Postby JamieConway88 » January 17th, 2018, 11:17 pm

It seems that the swapped engine clutch is not connecting properly to the transmission and may be binding up causing the engine to not start. Try unbolting the transmission and sliding it out, and then try turning the engine over by hand. If the engine cranks by hand, then the clutch was binding up. If the engine does not crank by hand, then there is an issue with the engine internally.

Advertisement

Return to “SUBARU”

Who is online

Users browsing this forum: No registered users and 1 guest