TriniTuner.com  |  Latest Event:  

Forums

Please help Mazda 3 dash issue

MAZDA People United - it continues here

Moderator: 3ne2nr Mods

the used
Ricer
Posts: 23
Joined: November 17th, 2008, 9:36 am
Location: central

Please help Mazda 3 dash issue

Postby the used » December 6th, 2017, 9:52 pm

So this is whats happening

- the car got a left side hit and was repaired
- the car had lights on , in the dash
- ABS , CHECK ENGINE and the car was stuck on AT mode
- did a diagnostic and sorted out the ABS which was a loose wire in the fuse box. the Abs came off after
- now the tiptronic wasnt engaging also the speedometer wasnt working also.
- now every time i start the car the speedometer works correctly and the tiptronic works for about 1 minute until- --
- the AT light on the dash engages when the car crosses 50mph and the speedometer stops working also the tiptronic
stops working
- removed the battery pole .. everything except the speedometer works fine until i switch off the ignition

please help
whatsapp or anything 3084581

Advertisement
User avatar
skylinechild
punchin NOS
Posts: 4414
Joined: January 13th, 2008, 11:38 pm
Location: In a Skyline

Re: Please help Mazda 3 dash issue

Postby skylinechild » December 9th, 2017, 1:56 pm

the used wrote:So this is whats happening

- the car got a left side hit and was repaired
- the car had lights on , in the dash
- ABS , CHECK ENGINE and the car was stuck on AT mode
- did a diagnostic and sorted out the ABS which was a loose wire in the fuse box. the Abs came off after
- now the tiptronic wasnt engaging also the speedometer wasnt working also.
- now every time i start the car the speedometer works correctly and the tiptronic works for about 1 minute until- --
- the AT light on the dash engages when the car crosses 50mph and the speedometer stops working also the tiptronic
stops working
- removed the battery pole .. everything except the speedometer works fine until i switch off the ignition

please help
whatsapp or anything 3084581


it sounds as though you may have a transmission solenoid failure issue

get the car scanned again... it could also be the main harness was damaged in the accident.. but i doubt it.
get car ecu /tcu scanned and report back.

Advertisement

Return to “MAZDA”

Who is online

Users browsing this forum: No registered users and 1 guest