TriniTuner.com  |  Latest Event:  

Forums

Ranger temperature problem

From Escorts to Rangers - First On Race Day

Moderator: 3ne2nr Mods

fullrace1980
Riding on 13's
Posts: 14
Joined: May 12th, 2015, 2:47 pm

Ranger temperature problem

Postby fullrace1980 » May 17th, 2019, 8:47 pm

I’ve got a 2010 ranger
I recently did a conversation to electric fans because with my clutch fan my van started over heating n now when my vehicle is parked for about 15-20 mins the temp gauge (external digital gauge) goes up but once I mash d acceleration pedal d temp gauge does start to go back down.... I service radiator change water pump change thermostat also change coolant n same problem
once d external gauge reach 110deg d dash gauge wud start to go up....
Everyone advised is to remove the thermostat but I don’t want to.... Any help as to how I can rectify dis problem???

Advertisement
User avatar
skylinechild
3ne2nr Toppa Toppa
Posts: 5520
Joined: January 13th, 2008, 11:38 pm
Location: In a Skyline

Re: Ranger temperature problem

Postby skylinechild » May 25th, 2019, 8:24 pm

fullrace1980 wrote:I’ve got a 2010 ranger
I recently did a conversation to electric fans because with my clutch fan my van started over heating n now when my vehicle is parked for about 15-20 mins the temp gauge (external digital gauge) goes up but once I mash d acceleration pedal d temp gauge does start to go back down.... I service radiator change water pump change thermostat also change coolant n same problem
once d external gauge reach 110deg d dash gauge wud start to go up....
Everyone advised is to remove the thermostat but I don’t want to.... Any help as to how I can rectify dis problem???



was all the air bled out of the system properly.??

trapped air bubbles cause the sensor to give different temp readings.

turn off ac turn the temp control to hot and then bleed out all air using a spill free funnel...

report back and let us know.

fullrace1980
Riding on 13's
Posts: 14
Joined: May 12th, 2015, 2:47 pm

Re: Ranger temperature problem

Postby fullrace1980 » June 2nd, 2019, 12:10 am

I change d cap
Workin gud so far

Advertisement

Return to “FORD”

Who is online

Users browsing this forum: No registered users and 4 guests