TriniTuner.com  |  Latest Event:  

Forums

2013 wildtrak not starting

Diesel, Gas, 4x4, 4x2

Moderator: 3ne2nr Mods

Forum rules
This forum is for discussions on Trucks and Pickups only!
DO NOT POST ADS IN HERE
WTB (Want to buy), LF (Looking for), EOI (Expression of Interest) or FS (For sale) topics etc will be deleted.
If you are looking for a part please search or post in the Auto Parts Classifieds.
Please keep all discussion professional and technical. Opinions are welcomed, however trolling, spamming and bashing will not be tolerated.
User avatar
civicman
3NE 2NR for life
Posts: 200
Joined: March 22nd, 2004, 10:17 am

2013 wildtrak not starting

Postby civicman » November 4th, 2015, 7:41 pm

Anyone knows of a mechanic that good with Ford

Van just tumbles starts and dies off in 10 seconds.
Can't rev the engine.

Advertisement
User avatar
supercharged turbo
30 pounds of Boost
Posts: 2516
Joined: January 19th, 2011, 6:53 pm
Location: turn around

Re: 2013 wildtrak not starting

Postby supercharged turbo » November 4th, 2015, 7:45 pm

Check engine light on?

User avatar
Toyopet
Chronic TriniTuner
Posts: 679
Joined: July 20th, 2008, 10:45 pm
Location: On the road
Contact:

Re: 2013 wildtrak not starting

Postby Toyopet » November 4th, 2015, 11:51 pm

More than likely the problem stems from it being a ford. Should have gotten an L200.

Could be a sensor or the turbo, but get it scanned first.

User avatar
supercharged turbo
30 pounds of Boost
Posts: 2516
Joined: January 19th, 2011, 6:53 pm
Location: turn around

Re: 2013 wildtrak not starting

Postby supercharged turbo » November 5th, 2015, 12:10 am

What model Ford?

zaria
Trinituner Peong
Posts: 437
Joined: January 22nd, 2007, 8:42 am
Location: cunupia

Re: 2013 wildtrak not starting

Postby zaria » November 5th, 2015, 6:31 am

How did problem start?on its own or after you did something?
like the other tuner asked,any error codes?
Not starting can be a long list of problems.
But my guess (I'm not a mechanic)
Butterfly flap on intake manifold.maybe stuck or not working
Air leak in fuel system or issue with fuel delivery.
Bad airflow sensor.
Let's us know if you got through and the cause.

User avatar
civicman
3NE 2NR for life
Posts: 200
Joined: March 22nd, 2004, 10:17 am

Re: 2013 wildtrak not starting

Postby civicman » November 5th, 2015, 8:32 am

Drove van to bank car park came back after 20 mis
Can't start
But anyone knows who I can take it to
Check engine light not on
Took it to a guy his scanner not picking up any error codes

User avatar
BRZ
Riding on 16's
Posts: 1165
Joined: August 16th, 2012, 8:21 am

Re: 2013 wildtrak not starting

Postby BRZ » November 5th, 2015, 8:58 am

2013??? er the DEALER!

zaria
Trinituner Peong
Posts: 437
Joined: January 22nd, 2007, 8:42 am
Location: cunupia

Re: 2013 wildtrak not starting

Postby zaria » November 5th, 2015, 10:28 am

Well first try as the other tuner advised and
seek help from where it was purchased.
if that fails go into mac motors and see if
you can get a contact #for one of their mechs.

You can also try disconnecting battery for a few mins.
Doubt it will help but you got notging to loose.

zaria
Trinituner Peong
Posts: 437
Joined: January 22nd, 2007, 8:42 am
Location: cunupia

Re: 2013 wildtrak not starting

Postby zaria » November 5th, 2015, 10:48 am

Well first try as the other tuner advised and
seek help from where it was purchased.
if that fails go into mac motors and see if
you can get a contact #for one of their mechs.

You can also try disconnecting battery for a few mins.
Doubt it will help but you got notging to loose.

User avatar
sliderz1
TriniTuner 24-7
Posts: 7166
Joined: March 24th, 2010, 10:36 pm
Location: doing the humpty dance

Re: 2013 wildtrak not starting

Postby sliderz1 » November 5th, 2015, 12:36 pm

check your primer pump

User avatar
civicman
3NE 2NR for life
Posts: 200
Joined: March 22nd, 2004, 10:17 am

Re: 2013 wildtrak not starting

Postby civicman » November 5th, 2015, 5:53 pm

Few guys came with scan tools
None able to read any code
Sent it down to m rampersad
This evening waiting to get word from them

zaria
Trinituner Peong
Posts: 437
Joined: January 22nd, 2007, 8:42 am
Location: cunupia

Re: 2013 wildtrak not starting

Postby zaria » November 6th, 2015, 8:25 am

Ok.
Keep us informed.
My wild track has been parked for 2 months.
Going start her up today.hopefully won't have issues.

User avatar
1UZFE
3ne2nr Toppa Toppa
Posts: 5032
Joined: May 6th, 2011, 10:55 am

Re: 2013 wildtrak not starting

Postby 1UZFE » November 6th, 2015, 9:09 am

In for info. Although u did d first thing last.

zaria
Trinituner Peong
Posts: 437
Joined: January 22nd, 2007, 8:42 am
Location: cunupia

Re: 2013 wildtrak not starting

Postby zaria » November 10th, 2015, 3:45 pm

Any update?

User avatar
civicman
3NE 2NR for life
Posts: 200
Joined: March 22nd, 2004, 10:17 am

Re: 2013 wildtrak not starting

Postby civicman » November 13th, 2015, 6:57 am

So after the long wait by m rampersad.

It was the EGR valve.
Stuck in the open position so too much exhaust gas going back in the engine causing the van to die off after starting.

This egr valve apparently is an issue with the fords (or the shipment with my van) .
The mechanics at M rampersad said they had this problem on a few wildtrak.

I actually paid for an egr valve service on the recommendation of the seller in august.

Guess they took my money and didn't do @$$ with the van then.

User avatar
BRZ
Riding on 16's
Posts: 1165
Joined: August 16th, 2012, 8:21 am

Re: 2013 wildtrak not starting

Postby BRZ » November 13th, 2015, 12:26 pm

BLANK the EGR valve , it only destroys your engine with the nasty quality of diesel we have locally.

User avatar
civicman
3NE 2NR for life
Posts: 200
Joined: March 22nd, 2004, 10:17 am

Re: 2013 wildtrak not starting

Postby civicman » November 13th, 2015, 3:05 pm

yeh looking to do that now

kriticalkase
3NE 2NR for life
Posts: 207
Joined: July 11th, 2007, 2:35 am

Re: 2013 wildtrak not starting

Postby kriticalkase » November 13th, 2015, 7:44 pm

Hey is this the 2.2 or the 3.2?

As far as I know based on info from Ford the 3.2 does not carry an EGR valve. Only the 2.2 has one.

User avatar
civicman
3NE 2NR for life
Posts: 200
Joined: March 22nd, 2004, 10:17 am

Re: 2013 wildtrak not starting

Postby civicman » November 13th, 2015, 8:02 pm

2.2

kriticalkase
3NE 2NR for life
Posts: 207
Joined: July 11th, 2007, 2:35 am

Re: 2013 wildtrak not starting

Postby kriticalkase » November 13th, 2015, 11:13 pm

I stand corrected. Apparently there are 3.2 with an EGR valve in some countries. I hope ford tdad didn't mislead me.

zaria
Trinituner Peong
Posts: 437
Joined: January 22nd, 2007, 8:42 am
Location: cunupia

Re: 2013 wildtrak not starting

Postby zaria » November 16th, 2015, 11:46 am

Anyone knows where I can get the blanking plate?

Advertisement

Return to “Trucks & Pickups”

Who is online

Users browsing this forum: No registered users and 4 guests