TriniTuner.com  |  Latest Event:  

Forums

Wlt oil leak

Diesel, Gas, 4x4, 4x2

Moderator: 3ne2nr Mods

Forum rules
This forum is for discussions on Trucks and Pickups only!
DO NOT POST ADS IN HERE
WTB (Want to buy), LF (Looking for), EOI (Expression of Interest) or FS (For sale) topics etc will be deleted.
If you are looking for a part please search or post in the Auto Parts Classifieds.
Please keep all discussion professional and technical. Opinions are welcomed, however trolling, spamming and bashing will not be tolerated.
User avatar
roti102
Street 2NR
Posts: 92
Joined: January 25th, 2006, 8:56 am

Wlt oil leak

Postby roti102 » April 9th, 2018, 5:46 pm

Anyone had any oil leak problems with the 2.5 WLT engines? I have one right above the vacuum pump and changed seals already. Still leaking

Advertisement
User avatar
rmrunner
Chronic TriniTuner
Posts: 654
Joined: April 6th, 2009, 3:13 pm

Re: Wlt oil leak

Postby rmrunner » April 9th, 2018, 6:44 pm

which seal did you replace? Chances are if the leak is coming from above the vacuum pump it will be the cam shaft seal leaking. If you changed the cam shaft seal and it still leaks, two causes are that 1) Seal was not installed properly 2) Engine has high positive crankcase pressure, which is forcing the oil out the seal(basically this engine going to need rebuilding soon). It also has an injector pump oil seal, you need to take off the timing cover and verify where the build up is

User avatar
roti102
Street 2NR
Posts: 92
Joined: January 25th, 2006, 8:56 am

Re: Wlt oil leak

Postby roti102 » April 9th, 2018, 6:54 pm

No oil by the cam shafts. I'm more looking at the injection pump oil seal. I guess. Hmmm

User avatar
roti102
Street 2NR
Posts: 92
Joined: January 25th, 2006, 8:56 am

Re: Wlt oil leak

Postby roti102 » April 9th, 2018, 7:17 pm

Wouldn't it be diesel fuel if it was the injection pump oil seal?

User avatar
roti102
Street 2NR
Posts: 92
Joined: January 25th, 2006, 8:56 am

Re: Wlt oil leak

Postby roti102 » April 12th, 2018, 10:52 am

Yup. Pulled it down and it was the injection pump oil seal. Changed it and it seems ok now.

Advertisement

Return to “Trucks & Pickups”

Who is online

Users browsing this forum: No registered users and 1 guest