TriniTuner.com  |  Latest Event:  

Forums

[FIXED] 2006 Kia Sorento ABS FL Sensor Error

Sportage, Sorento, Soul, Rio, Cerato, Optima

Moderator: 3ne2nr Mods

moneybagzkd
Riding on 13's
Posts: 12
Joined: December 9th, 2014, 6:47 pm

[FIXED] 2006 Kia Sorento ABS FL Sensor Error

Postby moneybagzkd » December 9th, 2014, 7:01 pm

Hey guys, I'm having an issue with my vehicle's ABS sensor. I was driving around one day when the ABS light came on, so I went and got it checked, realizing that the error from the diagnostic scan said, "Front Left ABS Sensor Short/Break".

Upon inspection, apparently the clamp that held the ABS sensor's wire in tact, had fallen off and the wire was rubbing so much on the wheel axle that it had cut and broke off. I re-joined the wires, two of them, then strapped up the wire higher up so it won't drag, then went for a drive.

The light remained on so I had a guy try to clear the code. However, it still wasn't clearing. Then I was told the sensor might be bad. I would like to inspect it myself closely again and test it to see if it is actually bad, however, can you guys let me know if this is usual? or if there is any other way I can test it to figure out what the problem is?

Also, if the sensor is actually bad, where can I get a replacement, (other than the firm's price of almost $600), at a reasonable price?, or if any of you guys has a spare? And what other tips might you guys recommend I do?

Vehicle Specs:
Kia Sorento 2006
Turbo EX
2.5 Diesel

Thanks for any advice.
Last edited by moneybagzkd on December 11th, 2014, 2:34 pm, edited 1 time in total.

Advertisement
moneybagzkd
Riding on 13's
Posts: 12
Joined: December 9th, 2014, 6:47 pm

Re: 2006 Kia Sorento ABS FL Sensor Error

Postby moneybagzkd » December 11th, 2014, 2:33 pm

Hey guys, I managed to fix the problem. Apparently there was another break in the wire at the base of the sensor itself. Had to grind back piece of the sensor's plastic end to expose more of the wire, and then resoldered the wires and it worked. No more abs light or error.

Also tested the abs on the road to make sure it was functioning properly for that tire and it worked as usual. So don't need another new sensor anymore.

Thanks anyway.

Advertisement

Return to “KIA”

Who is online

Users browsing this forum: No registered users and 2 guests