TriniTuner.com  |  Latest Event:  

Forums

SOLVED...Help AE100 5afe probs check light ON, No Power

It's all about 4AGE, NZE, 3SGTE, 1JZ, 2JZ etc.

Moderator: 3ne2nr Mods

User avatar
Around
3NE 2NR for life
Posts: 140
Joined: January 28th, 2006, 10:20 am
Location: Arima
Contact:

SOLVED...Help AE100 5afe probs check light ON, No Power

Postby Around » July 6th, 2010, 12:09 pm

My 100 check light ON first time EVER...... does come off sometimes, but on longer than off
When i tried to jumper diagnostic ODB1 port
1. sometime number 1 code - which means no problem i think
2. yesterday no response / no code flashing

Symptoms , when check light ON
1. want to cut OFF in reverse
2. lack of power/ acceleration
3. no more than 3000 rpm ( and reving when it reach deh)

When check light OFF car works fine. To be honest car ent tune up in a while.
but changed so far- Throttle boby cleaned was having idle probs around February,& plugs changed yesterday
Any suggestions?? any of y'all had / seen this before ?
Last edited by Around on July 10th, 2010, 7:58 am, edited 2 times in total.

Advertisement
toyotajumbie
Trinituner Peong
Posts: 414
Joined: April 27th, 2007, 9:48 am
Location: GOD without man is still GOD but man without GOD is nothing
Contact:

Re: Help AE100 5afe probs check light ON, No Power

Postby toyotajumbie » July 6th, 2010, 10:52 pm

Start with a full tune up inclusive of injector cleaning and then work from there.

laffy20
Riding on 13's
Posts: 5
Joined: July 29th, 2009, 10:40 am

Re: Help AE100 5afe probs check light ON, No Power

Postby laffy20 » July 7th, 2010, 1:28 am

what u can do is when the light comes on take off a battery pole for about 15mins and then put it back on start and see if the light still appears if it come off its a sensor in your engine cant remember offhand which oneis it exactly but try that ans then explain it to the mechanic.

User avatar
Around
3NE 2NR for life
Posts: 140
Joined: January 28th, 2006, 10:20 am
Location: Arima
Contact:

Re: Help AE100 5afe probs check light ON, No Power

Postby Around » July 7th, 2010, 6:32 am

thanks toyotajumbie laffy20 & laffy20 - i think u r right bout d sensor cause sometimes she drive for a 15 - 25 mins ok no check light then when it on probs, will do tune & scan , and ill post my result

User avatar
Hook
3NE 2NR Moderator
Posts: 13721
Joined: January 18th, 2004, 9:55 am
Location: The 6%.

Re: Help AE100 5afe probs check light ON, No Power

Postby Hook » July 7th, 2010, 10:59 am

We have so much information floating around this forum with threads/posts on how to retrieve and read diagnostic codes from the 4A engines. One's even a sticky.

Bear in mind that it may even be a transmission error code as well. Have the overdrive on when jumping TE1 and E1 on the diagnostic port. If there's no transmission errors, the "O/D Off" light will flash quickly, if there IS an error code...well...read on...

A self-diagnosis function is built into the electrical control system. Warning is indicated by the overdrive OFF indicator light.

Note: Warning and diagnostic codes can be read only when the overdrive switch is ON. If OFF, the overdrive OFF light is lit continuously and will not blink.

a. If a malfunction occurs within the speed sensors (No.1 or 2) or solenoids (No.1, 2 or 4), the overdrive OFF light will blink to warn the driver. However, there will be no warning of a malfunction with lock-up solenoid.
b. The diagnostic code can be read by the number of blinks of the overdrive OFF indicator light when terminals TE1 and E1 are connected.
c. The throttle position sensor or brake signal are not indicated, but inspection can be made by checking the voltage at terminal TT of the check connector.
d. The signals to each gear can be checked by measuring the voltage at terminal TT of the check connector while driving.

The diagnostic code (trouble code) is retained in memory by the CPU (of TCCS ECU) and due to back-up voltage, is not canceled out when the engine is turned off. Consequently, after repair, it is necessary to turn the ignition switch off and remove the fuse EFI (15A) or disconnect the TCCS ECU connector to cancel out the diagnostic (trouble) code.

Note: Low battery voltage will cause faulty operation of the diagnosis system. Therefore. always check the battery first. Use a voltmeter and ohmmeter that have an impedance of at least 10K Ohm/Volt.

Check "O/D Off" Indicator Light:

1. Turn the ignition switch ON.
2. The "O/D Off" light will come on when the O/D switch is placed at OFF.
3. When the O/D switch is set to ON, the "O/D Off" light should go out. If the "O/D Off" light flashes when the O/D switch is set to ON, the electronic control system is faulty.

Read Diagnostic Code:

1. Turn ignition switch and o/d switch to ON. Do not start the engine.
Engine NOTE: Warning and diagnostic codes can be read only when the overdrive switch is ON. If OFF, the overdrive OFF light will light continuously and will not blink.

2. Connect TE1, and E1, terminals of check connector.
Read the diagnostic code as indicated by the number of times the O/D OFF light flashes.

Image

Diagnostic Code Indication:

If the system is operating normally, the light will flash two times per second.

In the event of a malfunction, the light will flash 1 time per second. The number of blinks will equal the first number and, after 1.5 seconds pause, the second number of the two digit diagnostic code. If there are two or more codes, there will be a 2.5 seconds pause between each.

NOTE: In the event of several trouble codes occurring simultaneously, indication will begin from the smaller value and continue to the larger.

Image


User avatar
Around
3NE 2NR for life
Posts: 140
Joined: January 28th, 2006, 10:20 am
Location: Arima
Contact:

Re: SOLVED...Help AE100 5afe probs check light ON, No Power

Postby Around » July 9th, 2010, 8:23 pm

Thanks all contributers, got rolla sorted out it was a defective ECU, i guess when u dat old...in model/date of manufacture... it could happen

props to my boy Marcus.... La horquetta/ Deigo steps as follows

1. Tried to scan car using LAUNCH diagnostic tool...tool didn't power up until we used external ground lead......somethings wrong....Y we getting power on port but no ground... and all who know in data systems ground is real essential for zero reference as its ones and zeroes we dealing with. Even with tool powered UP, no communication to ECU possible....... Change battery as cells kindah weak and this could hamper diagnostic tool so d tool say eh retried.... failure

2. Tried self-diagnosis function as hook said above ECU light on but not blinking codes just ....ON & stationary

3. Checked ECU connector & continuity from ECU to diagnostic port in bonnet for all pins
....result OK

4 Bought FU ECU swapped out, re gaped plugs, cleaned distributor due to oil leak on seal

5. Bounce starter ........start in half aah turn..We have lift OFF

6. No check light........ Idle & run car......Check still off.......Run car some more.....shes back.....who say rolla forever. Its not mechanical, rolla stands d test of time.. i should have never doubted...my baby

thanks for listening u guys.... :lol: good luck to my fellow rollas out dey 0X

User avatar
Around
3NE 2NR for life
Posts: 140
Joined: January 28th, 2006, 10:20 am
Location: Arima
Contact:

Re: SOLVED...Help AE100 5afe probs check light ON, No Power

Postby Around » July 9th, 2010, 8:28 pm

she still need some more attention eh but dis month.....$$$....is for something else

laffy20
Riding on 13's
Posts: 5
Joined: July 29th, 2009, 10:40 am

Re: SOLVED...Help AE100 5afe probs check light ON, No Power

Postby laffy20 » July 9th, 2010, 8:45 pm

thats a mc rolla starts with half of a turn. fire bun dem other fella nissan, bushi all ah dem lol lol

Advertisement

Return to “TOYOTA”

Who is online

Users browsing this forum: No registered users and 2 guests