TriniTuner.com  |  Latest Event:  

Forums

The A/C problem thread. Check here first! (Mods plz sticky)

Tuning advice, problems and troubleshooting

Moderator: 3ne2nr Mods

User avatar
pandu
Street 2NR
Posts: 74
Joined: April 6th, 2008, 1:26 pm
Location: somewhere with coffee

The A/C problem thread. Check here first! (Mods plz sticky)

Postby pandu » August 5th, 2008, 12:13 pm

Seeing as there are an almost infinite number of a/c problem threads, and seeing as the creators of these threads tend to not know how to describe the problem in the topic header('ac problem' is not an adequate explanation people! Jesus!), I will try to place most of the ac problem threads in here and give a little description next to the link, maybe even sort it out. I'll cross that bridge when I get there.

FILTER PROBLEMS:

Accessing and cleaning filters.
http://forums.trinituner.com/forums/vie ... +condition

Stuff on washing filters.
http://forums.trinituner.com/forums/vie ... +condition



COMPRESSOR PROBLEM:

Coil heating and blowing fuse
http://forums.trinituner.com/forums/vie ... p?t=198982

Refurbishing a compressor
http://forums.trinituner.com/forums/vie ... +condition

Getting a new compressor
http://forums.trinituner.com/forums/vie ... +condition

random other stuff
http://forums.trinituner.com/forums/vie ... +condition




DRYER PROBLEMS:

clogged?
http://forums.trinituner.com/forums/vie ... +condition





COOLING PROBLEMS:

Leaky evaporator
http://forums.trinituner.com/forums/vie ... +condition

Gas leak out
http://forums.trinituner.com/forums/vie ... +condition

Coil bad
http://forums.trinituner.com/forums/vie ... +condition

dryer bottle
http://forums.trinituner.com/forums/vie ... +condition

Belts not spinning
http://forums.trinituner.com/forums/vie ... +condition

condenser bad
http://forums.trinituner.com/forums/vie ... +condition

faulty relay, radiator fan not spinning in fwd car with ac on
http://forums.trinituner.com/forums/vie ... p?t=201006




VENT PROBLEMS:

Vents not giving out enough air. As a side note, my dad had leaves, twigs and all sort of crap in his, so that can also be a problem if you buy it RORO.
http://forums.trinituner.com/forums/vie ... +condition




AC SMELLING NASTY (EXHAUST, MUSTY,etc,):

Musty smell, possible sponge filter
http://forums.trinituner.com/forums/vie ... +condition

Exhaust fumes
http://forums.trinituner.com/forums/vie ... +condition

nasty smell, possibly hose damaged
http://forums.trinituner.com/forums/vie ... +condition

Getting rid of musty smell with chemicals, etc.
http://forums.trinituner.com/forums/vie ... +condition




AC CAUSING OVERHEATING OF CAR:

Overheats when idling with ac on.
http://forums.trinituner.com/forums/vie ... +condition




AC CAUSES CAR TO CUT OFF:

Idles good, cuts off when car gears down
http://forums.trinituner.com/forums/vie ... +condition

car cuts off when driving with ac on
http://forums.trinituner.com/forums/vie ... +condition




AC AND TURBO:

Intercooler can cause problems.
http://forums.trinituner.com/forums/vie ... +condition


UPDATE: This site has some pretty good differential diagnoses for a/c problems as well, most of them can be found in the above links, but you can get an explanation and certain DIY checks here:

http://www.aa1car.com/library/ac98.htm


A/c Repair shops:

1) Cool Tech in Balmain, Couva - they rather iffy. If you need to gas up, or change a filter, or you are bringing the actual part for them to replace, then no problem. As far as them figuring out the problem for the first time, i'd give it a 50/50 shot...

2) Rakesh in St. Helena - He and his brother do excellent work, and they don't buss yuh throat with price. 712-8217.

3) Ryanair, Cane Farm Road, Tacarigua - Again, mixed reviews about this place. General consensus is that they ARE expensive.

4) Cool Access - 679-7744/ 750-3885 (Bobby). Freeport.


Comment in the thread about other places you all go to, and I will compile them....
Last edited by pandu on December 24th, 2010, 9:24 pm, edited 4 times in total.

User avatar
VexXx Dogg
TriniTuner 24-7
Posts: 14601
Joined: May 1st, 2003, 10:23 am
Location: ���

Postby VexXx Dogg » August 5th, 2008, 2:35 pm

^ good stuff, well done.

User avatar
Rainman
3ne2nr Toppa Toppa
Posts: 5135
Joined: July 25th, 2005, 11:15 am
Location: Not offshore!
Contact:

Postby Rainman » August 9th, 2008, 12:31 am

when i bought my mazda 3 RORO i found that there was a musty smell coming from the AC. It rarely happened but it still bugged me so i bought the filters from SS and used the walkthrough below and trust me it made the world of difference.



http://www.mazda3forums.com/index.php?topic=96166.0 (this is the guide that i used)

User avatar
pandu
Street 2NR
Posts: 74
Joined: April 6th, 2008, 1:26 pm
Location: somewhere with coffee

Postby pandu » September 21st, 2008, 10:04 am

Bump.

User avatar
~Vēġó~
3NE 2NR Moderator
Posts: 45670
Joined: April 18th, 2003, 12:18 am
Location: Being the Change that I want to See
Contact:

Postby ~Vēġó~ » September 21st, 2008, 2:48 pm

See Best of Tech.......

User avatar
1800GSRLANCER
Sweet on this forum
Posts: 353
Joined: January 25th, 2008, 7:33 pm

Postby 1800GSRLANCER » October 3rd, 2009, 7:42 am

thats the shiznit right their man excellent post :arrow:

User avatar
Adrenalinerush
Chronic TriniTuner
Posts: 653
Joined: January 27th, 2004, 12:46 pm
Location: Off the rocks...
Contact:

Postby Adrenalinerush » October 3rd, 2009, 1:15 pm

well compiled info there dred... :wink:

User avatar
SNIPER 3000
Riding on 17's
Posts: 1550
Joined: February 18th, 2007, 3:58 pm

Postby SNIPER 3000 » October 4th, 2009, 9:30 pm

Great job!

User avatar
subzerounlimited
Street 2NR
Posts: 94
Joined: November 3rd, 2006, 2:48 am

Postby subzerounlimited » October 5th, 2009, 4:51 pm

excellent work

User avatar
Mark!
Trying to catch PATCH AND VEGA
Posts: 6562
Joined: March 6th, 2009, 6:19 pm
Location: Old Trafford

Postby Mark! » October 11th, 2009, 10:07 am

if only i did see this thread sooner

User avatar
IvanTerrors
Trinituner Peong
Posts: 497
Joined: July 25th, 2007, 8:53 pm
Location: Trinidad
Contact:

Postby IvanTerrors » October 12th, 2009, 8:15 pm

when ac is on i hear a sqeaking noise from engine when it is off noise is not there

User avatar
1800GSRLANCER
Sweet on this forum
Posts: 353
Joined: January 25th, 2008, 7:33 pm

Postby 1800GSRLANCER » October 12th, 2009, 8:17 pm

that's probably the compressor or the belt on the compressor... go by any a/c place they would be able to tell you exactly what it is...

User avatar
IvanTerrors
Trinituner Peong
Posts: 497
Joined: July 25th, 2007, 8:53 pm
Location: Trinidad
Contact:

Postby IvanTerrors » October 13th, 2009, 10:10 pm

scene

User avatar
1800GSRLANCER
Sweet on this forum
Posts: 353
Joined: January 25th, 2008, 7:33 pm

Postby 1800GSRLANCER » October 14th, 2009, 7:17 am

yea word..

User avatar
DF1_2nR
Trinituner Peong
Posts: 436
Joined: February 12th, 2006, 10:25 pm
Location: Looking for $$$

Postby DF1_2nR » November 13th, 2009, 9:03 am

I need a reliable place to get my AC checked that wont overcharge me in the east preferrably.

Changed my transmission and added an oil cooler recently and since then the system just blowing hot air.

Gimme some recommendations please.

User avatar
1UZFE
punchin NOS
Posts: 4966
Joined: May 6th, 2011, 10:55 am

Re: The A/C problem thread. Check here first! (Mods plz stic

Postby 1UZFE » September 10th, 2011, 12:02 pm

Firstly I have a B15.
I started my car and turned on the AC it was cold as usual. After driving for 5 mins I noticed the AC was not cold, I then noticed that the button was off( the light was off). The button is lit when I turn on the AC but this time the button was on the pressed position and the compressor was off. I noticed this when I was driving I had to press the button on and off for the AC to come on, then 5 mins later I would not feel the compressor on ,and the light on the "ON" button would be off although it was pressed.
Advice please.

User avatar
*$kїđž!™
TriniTuner 24-7
Posts: 11095
Joined: December 25th, 2006, 2:58 pm
Location: VIP SECTION

Re: The A/C problem thread. Check here first! (Mods plz stic

Postby *$kїđž!™ » September 21st, 2011, 4:18 pm

when i turn on my ac compressor remains on.....

it does not enter into the "cycling " mode.....the a/c fans just runs continually.......

even if i put it on hot...hot air comes tru but ac compressor and fan is still on!!!

User avatar
ruffrider27
Riding on 16's
Posts: 1232
Joined: January 27th, 2008, 9:06 am
Location: Ontario

Re: The A/C problem thread. Check here first! (Mods plz stic

Postby ruffrider27 » September 29th, 2011, 3:48 am

notice it have a saying "ac just needs gassing up" when they put up a vehicle up f/s,first thing were the gas went in the first place, you will have to locate the leak in the system,get it welded or part replaced, test again with com. air,then you gas up.

and ppl go by a professional /know what they doing ,not around d corner a/c guy it will cost cheaper.

User avatar
*$kїđž!™
TriniTuner 24-7
Posts: 11095
Joined: December 25th, 2006, 2:58 pm
Location: VIP SECTION

Re: The A/C problem thread. Check here first! (Mods plz stic

Postby *$kїđž!™ » September 29th, 2011, 11:05 pm

1UZFE wrote:Firstly I have a B15.
I started my car and turned on the AC it was cold as usual. After driving for 5 mins I noticed the AC was not cold, I then noticed that the button was off( the light was off). The button is lit when I turn on the AC but this time the button was on the pressed position and the compressor was off. I noticed this when I was driving I had to press the button on and off for the AC to come on, then 5 mins later I would not feel the compressor on ,and the light on the "ON" button would be off although it was pressed.
Advice please.


call jason at parts2go.....221 8950

he will tell u whats your problem and he has new parts also.......

User avatar
konartis
Shifting into 6th
Posts: 2123
Joined: January 11th, 2011, 11:22 am
Location: south

Re: The A/C problem thread. Check here first! (Mods plz stic

Postby konartis » October 15th, 2011, 9:03 pm

dont knw if anyone can help...i recently changed the A/C compressor on my car, the dryer bottle and cleaned the filter..everything topped up..the thing is that when the sun is really hott and i put on my ac, it takes a really long while to cool the car, if the place os cool, it cools fast...in rain its freezing...but its completely different in hott weather, almost 1/2 hour to cool and it doesnt even be really cold...if there is a car in-front i smell the exhaust...could it be that hot air is coming into the car somewhere? any thoughts will be appreciated! thanks!

User avatar
*$kїđž!™
TriniTuner 24-7
Posts: 11095
Joined: December 25th, 2006, 2:58 pm
Location: VIP SECTION

Re: The A/C problem thread. Check here first! (Mods plz stic

Postby *$kїđž!™ » October 16th, 2011, 2:27 am

PM parts2go.....he'll advise u.....

User avatar
RoadRunnerGTR
3NE 2NR for life
Posts: 138
Joined: August 8th, 2010, 2:38 pm
Location: Cruising...

Re: The A/C problem thread. Check here first! (Mods plz stic

Postby RoadRunnerGTR » January 21st, 2012, 12:28 pm

now thats good advice!

User avatar
crysys
Street 2NR
Posts: 87
Joined: March 17th, 2008, 9:09 pm
Location: Launching out...

Re: The A/C problem thread. Check here first! (Mods plz stic

Postby crysys » February 2nd, 2012, 3:27 pm

hey peeps im lookin for an evaporator for an EK3 civic
any suggessions ?

User avatar
PARTS2go
3NE 2NR for life
Posts: 197
Joined: September 13th, 2011, 11:14 am

Re: The A/C problem thread. Check here first! (Mods plz stic

Postby PARTS2go » March 12th, 2012, 9:39 pm

4 a/c shops in the whole of Trinidad & Tobago?

NR8
Riding on 18's
Posts: 1822
Joined: January 14th, 2012, 2:20 pm

Re: The A/C problem thread. Check here first! (Mods plz stic

Postby NR8 » March 31st, 2012, 4:01 pm

I have a B12 that had the original engine and a/c system was redone last October. The compressor, condenser with dryer and refrigerant lines were replaced with B14 ones and the evaporator changed to an E24 type I believe. The system worked well at first but I never really heard the "clicking" sound that means the compressor is cycling like some tuners have said it should.
Now though, the a/c is only cold when driving fast/at night/raining but takes very long to get cold when it's hot outside/driving slow/idling, and it still doesn't get as cold.
Also, sometimes when pulling off from a dead stop with a/c on I hear a screeching sound. I've read that it could be the belt, but the engine was replaced with a QG15 earlier this year and both belts were changed. I chose to reuse the B14 compressor instead of buying the QG15 with compressor since the a/c technician had advised me that it should last for some time.
Can someone give some advice please? :(

User avatar
Knight Rider
Sweet on this forum
Posts: 358
Joined: April 13th, 2004, 8:01 am
Location: Behind The Wheel
Contact:

Re: The A/C problem thread. Check here first! (Mods plz stic

Postby Knight Rider » June 9th, 2012, 9:48 am

I need someone to service the evaporator on my Car's AC system. previous owners removed the cabin air filter. I want to replace it, but ened to clean the evaporator first. May also need to change the thermistor but will only be sure of that when the evaporator is cleaned.

User avatar
PARTS2go
3NE 2NR for life
Posts: 197
Joined: September 13th, 2011, 11:14 am

Re: The A/C problem thread. Check here first! (Mods plz stic

Postby PARTS2go » June 9th, 2012, 9:52 am

Find an a/c shop here!

viewtopic.php?f=12&t=443268

User avatar
src1983
18 pounds of Boost
Posts: 2386
Joined: February 17th, 2009, 11:09 am
Location: Somewhere

The A/C problem thread. Check here first! (Mods plz sticky)

Postby src1983 » July 4th, 2012, 10:11 am

Morning fellas,

Any of u guys have a number the ac technician in vistabella, located opposite happy hill bar and next to southern radiator works?

His name is Maraj

Thanks

User avatar
insanelunatic
3NE 2NR for life
Posts: 231
Joined: July 16th, 2009, 10:31 pm

Re: The A/C problem thread. Check here first! (Mods plz stic

Postby insanelunatic » August 7th, 2012, 7:49 pm

ok!! well i ran through the said thrends but not seeing my problem.....i own ah 99 mazda familia and when i turn on my ac ever so often i get an annoying "tick tick tick" sound.....if i gently press my gas pedel if goes away, bt keep in mind when iam driving no sound, but if i stop in traffic RPM drop below 1000 and noise again..... someone told me raising my idle screw wouldnt help........
Any idea why my compressor make such sound?

wingroad33
Street 2NR
Posts: 33
Joined: June 19th, 2012, 10:08 pm

y11 ac problem

Postby wingroad33 » September 22nd, 2012, 7:38 pm

hey guys i have ay11 wingroad qg15 engine at nights ac blows cold in the day while in traffic jus hot air while driving in the day no traffic the ac is cool not cold could anyone help with this problem

Advertisement

Return to “AUTOMOTIVE TECH”

Who is online

Users browsing this forum: No registered users and 13 guests