TriniTuner.com  |  Latest Event:  

Forums

Nissan B14 starting problems...

Sunny to Skyline - SR20, CA18, RB20-26, VG30 etc.

Moderator: 3ne2nr Mods

Chris00007
Street 2NR
Posts: 44
Joined: October 23rd, 2018, 8:12 pm

Nissan B14 starting problems...

Postby Chris00007 » July 12th, 2019, 7:09 pm

So I'm getting a terrible hard starting problem every morning or whenever I cut off the car for a few hours. It cranks for a long time before starting.

I thought it was a faulty fuel pressure regulator or injectors so I had the rail replaced and still nothing changed. My mechanic said it's not the fuel pump because the car runs extremely good otherwise.

If I cut off and start back within a few minutes, it starts very fast and with no issues so I don't think it's the starter here. I recently changed the battery and spark plugs so those can't be the issue. I need help ASAP!

Advertisement
User avatar
hong kong phooey
punchin NOS
Posts: 2847
Joined: July 10th, 2006, 8:37 am
Location: ah lorse

Re: Nissan B14 starting problems...

Postby hong kong phooey » July 13th, 2019, 1:48 am

I see you mentioned a mechanic
did he check the battery , plugs , and wires ,distributor or if is (coilpack) and your air filter

Although you say it tumbling for a while it could be your battery weak, any battery shop should be able to do a load test on it

Chris00007
Street 2NR
Posts: 44
Joined: October 23rd, 2018, 8:12 pm

Re: Nissan B14 starting problems...

Postby Chris00007 » July 13th, 2019, 7:46 am

hong kong phooey wrote:I see you mentioned a mechanic
did he check the battery , plugs , and wires ,distributor or if is (coilpack) and your air filter

Although you say it tumbling for a while it could be your battery weak, any battery shop should be able to do a load test on it

I changed the battery two weeks ago. New spark plugs, new air filter, changed distributer, new fuel pump.

The thing is, if I shut off and start back while the engine is still hot, it starts back without any problems.

User avatar
Spitfir3
punchin NOS
Posts: 3575
Joined: September 1st, 2009, 11:11 pm

Re: Nissan B14 starting problems...

Postby Spitfir3 » July 13th, 2019, 6:00 pm

clean the throttle body

Chris00007
Street 2NR
Posts: 44
Joined: October 23rd, 2018, 8:12 pm

Re: Nissan B14 starting problems...

Postby Chris00007 » July 13th, 2019, 6:35 pm

Spitfir3 wrote:clean the throttle body

This was also checked and the mechanic said it's fine. What I'm thinking about changing is the coolant temp sensor. The car is only hard to start when cold so maybe this is the cause.

Also, can the ignition switch cause this? I was told a bad ignition switch can cause cold starts but all accessories etc. works good when I turn the ignition.

adnj
Riding on 17's
Posts: 1547
Joined: February 24th, 2014, 2:55 pm

Re: Nissan B14 starting problems...

Postby adnj » July 13th, 2019, 7:07 pm

Anything that lowers the cranking speed of the starter will affect cold engine turn over.

You may want to check the crank spread by looking at crank RPMs. If the starter is not working at spec, then your B+ cable, ground cable, fusible links, cable clamps, ground points, and ignition switch should be looked at for high resistance. You can check for a lean cold engine fuel mix by spraying starter fluid in the intake.

User avatar
TurboSingh12
Riding on 16's
Posts: 1246
Joined: November 24th, 2014, 9:24 am
Location: Japan

Re: Nissan B14 starting problems...

Postby TurboSingh12 » July 15th, 2019, 10:58 am

Coolant temp is the sucker

Chris00007
Street 2NR
Posts: 44
Joined: October 23rd, 2018, 8:12 pm

Re: Nissan B14 starting problems...

Postby Chris00007 » July 15th, 2019, 11:02 pm

TurboSingh12 wrote:Coolant temp is the sucker

Is there a way to check it before changing it to be sure? Like if I unplug it and try starting in the morning, is it supposed to start properly?

Also this is kinda a stupid question but where exactly is this sensor? I think it's the one right next to the injectors rail (left side) with the connector with two wires but I'm not positive. If I unplug that and start the car, both fans kick in as soon as the car starts so I'm not sure.

Also it is a GA15de engine if that's any help

User avatar
TurboSingh12
Riding on 16's
Posts: 1246
Joined: November 24th, 2014, 9:24 am
Location: Japan

Re: Nissan B14 starting problems...

Postby TurboSingh12 » July 16th, 2019, 9:13 am

Chris00007 wrote:
TurboSingh12 wrote:Coolant temp is the sucker

Is there a way to check it before changing it to be sure? Like if I unplug it and try starting in the morning, is it supposed to start properly?

Also this is kinda a stupid question but where exactly is this sensor? I think it's the one right next to the injectors rail (left side) with the connector with two wires but I'm not positive. If I unplug that and start the car, both fans kick in as soon as the car starts so I'm not sure.

Also it is a GA15de engine if that's any help


What i usually do is take a piece off electrical wire and cut both ends and U it off on the jack and then start the car.If t starts on one bounce thats your problem.

Musical Doc
3NE 2NR for life
Posts: 215
Joined: January 22nd, 2013, 7:59 pm

Re: Nissan B14 starting problems...

Postby Musical Doc » August 9th, 2019, 9:41 am

Did you find the problem?

Chris00007
Street 2NR
Posts: 44
Joined: October 23rd, 2018, 8:12 pm

Re: Nissan B14 starting problems...

Postby Chris00007 » October 20th, 2019, 7:44 am

:fist:
Musical Doc wrote:Did you find the problem?

Yea man, sorry for the late reply but I recently just decided to change the fuel pump because a had a bit of extra money, and now it starts on one bounce all the time. The fuel pump was the culprit. I'd suggest you do a fuel pressure test if you getting this same problem bc the test showed that as soon as I switched off, all the fuel going right back into the tank and the rail not holding and pressure.

Advertisement

Return to “NISSAN”

Who is online

Users browsing this forum: No registered users and 4 guests