Page 1 of 1

Ranger temperature problem

Posted: May 17th, 2019, 8:47 pm
by fullrace1980
I’ve got a 2010 ranger
I recently did a conversation to electric fans because with my clutch fan my van started over heating n now when my vehicle is parked for about 15-20 mins the temp gauge (external digital gauge) goes up but once I mash d acceleration pedal d temp gauge does start to go back down.... I service radiator change water pump change thermostat also change coolant n same problem
once d external gauge reach 110deg d dash gauge wud start to go up....
Everyone advised is to remove the thermostat but I don’t want to.... Any help as to how I can rectify dis problem???

Re: Ranger temperature problem

Posted: May 25th, 2019, 8:24 pm
by skylinechild
fullrace1980 wrote:I’ve got a 2010 ranger
I recently did a conversation to electric fans because with my clutch fan my van started over heating n now when my vehicle is parked for about 15-20 mins the temp gauge (external digital gauge) goes up but once I mash d acceleration pedal d temp gauge does start to go back down.... I service radiator change water pump change thermostat also change coolant n same problem
once d external gauge reach 110deg d dash gauge wud start to go up....
Everyone advised is to remove the thermostat but I don’t want to.... Any help as to how I can rectify dis problem???



was all the air bled out of the system properly.??

trapped air bubbles cause the sensor to give different temp readings.

turn off ac turn the temp control to hot and then bleed out all air using a spill free funnel...

report back and let us know.

Re: Ranger temperature problem

Posted: June 2nd, 2019, 12:10 am
by fullrace1980
I change d cap
Workin gud so far