TriniTuner.com  |  Latest Event:  

Forums

Problems with the Meguiars Ultimate Polish

Tuning advice, problems and troubleshooting

Moderator: 3ne2nr Mods

CarmeloLabadie
Riding on 13's
Posts: 1
Joined: June 1st, 2021, 3:45 am

Problems with the Meguiars Ultimate Polish

Postby CarmeloLabadie » June 1st, 2021, 3:51 am

So I'm fairly new to detailing, but watched every video and read every "how to" that I could come across trying to pick up the basics. So I bought a 2004 Subaru last week (black) and while the paint didn't look horrible it had some swirl marks and hard water spots on the roof, so I decided to try Meguiars Ultimate Compound followed by a Maguiars Ultimate Polish using a PC 7424 polisher and buffing out by hand using microfiber cloths, needless to say the results were far less than satisfactory. First of all the compound failed to remove any of the swirl marks or water spots, this after repeated passes working in small areas, but the real problem was when I got to the polish, it was almost IMPOSSIBLE to remove by hand, even after using the PC in small 1' x 1' areas, using plenty of product; the entire car now has this hazy look to it. I even tried doing it again today using the Ultimate Polish by hand using a new foam applicator, and it turned out even worse...

Can you give me some tips on what I might be doing wrong?

User avatar
Dave
3NE 2NR Moderator
Posts: 16364
Joined: April 22nd, 2003, 8:07 am
Location: playing with above and below
Contact:

Re: Problems with the Meguiars Ultimate Polish

Postby Dave » June 1st, 2021, 5:59 am

I think the paint needed to be cleaned first.

Advertisement

Return to “AUTOMOTIVE TECH”

Who is online

Users browsing this forum: No registered users and 11 guests