TriniTuner.com  |  Latest Event:  

Forums

The Official CS Lancer Thread!

Mitsu Lancer, Evo, GSR, MIVEC, 4G**, GDI, Galant, Outlander, L200 Sportero/Triton etc.

Moderator: 3ne2nr Mods

User avatar
Hot Rod
punchin NOS
Posts: 3324
Joined: May 18th, 2003, 9:27 pm
Location: hmmm good question
Contact:

Re: The Official CS Lancer Thread!

Postby Hot Rod » October 10th, 2020, 10:25 pm

Fellas could u point me in a direction of a good cvt mechanic. Need some advice about mine. Thanks in advance

TheAutoDIYGuyYT
Street 2NR
Posts: 49
Joined: June 6th, 2017, 4:37 pm

Re: The Official CS Lancer Thread!

Postby TheAutoDIYGuyYT » January 14th, 2021, 7:49 pm

Hey guys...I have a local 2005 cs3 lancer with 4g18 and Cvt tranny. The original tranny failed on me, then I got a foreign used one from bamboo which failed after a few months...so I purchased a brand new cvt tranny about 2 years ago, however, today the transmission shift solenoids failed on me.

Is there anyone who does conversions from cvt to manual gearbox or normal auto for this model?

User avatar
ronsin1
punchin NOS
Posts: 3671
Joined: November 30th, 2005, 8:00 am
Contact:

Re: The Official CS Lancer Thread!

Postby ronsin1 » January 22nd, 2021, 6:27 am

TheAutoDIYGuyYT wrote:Hey guys...I have a local 2005 cs3 lancer with 4g18 and Cvt tranny. The original tranny failed on me, then I got a foreign used one from bamboo which failed after a few months...so I purchased a brand new cvt tranny about 2 years ago, however, today the transmission shift solenoids failed on me.

Is there anyone who does conversions from cvt to manual gearbox or normal auto for this model?
Wow thats a lot of bad luck

I know CVT transmission in CS3 thats lasted over 300K km without issues

Have you been changing transmission oil on time



The CVT generates a lot of heat and the SP111 oil breaks down in viscosity


I had two CS lancers with CVT transmission, I had the transmission oil changed at every 25k km to be safe and I also installed an external oil cooler

User avatar
ZeroOne
12 pounds of Boost
Posts: 2252
Joined: August 5th, 2008, 4:10 pm

Re: The Official CS Lancer Thread!

Postby ZeroOne » January 26th, 2021, 4:38 pm

ronsin1 wrote:
TheAutoDIYGuyYT wrote:Hey guys...I have a local 2005 cs3 lancer with 4g18 and Cvt tranny. The original tranny failed on me, then I got a foreign used one from bamboo which failed after a few months...so I purchased a brand new cvt tranny about 2 years ago, however, today the transmission shift solenoids failed on me.

Is there anyone who does conversions from cvt to manual gearbox or normal auto for this model?
Wow thats a lot of bad luck

I know CVT transmission in CS3 thats lasted over 300K km without issues

Have you been changing transmission oil on time



The CVT generates a lot of heat and the SP111 oil breaks down in viscosity


I had two CS lancers with CVT transmission, I had the transmission oil changed at every 25k km to be safe and I also installed an external oil cooler


I ran mine somewhere over 50k km last time i changed it.

It throws on the engine check light and a trans oil pressure low code when you connect a scan tool and thats when I changed mine.

I only use original mitsu sp3 oil

Not saying to follow my example and go 50k km before changing, I usually change around 30k km.

User avatar
fwape
Street 2NR
Posts: 54
Joined: July 19th, 2011, 11:49 am
Location: St. Lucia

Re: The Official CS Lancer Thread!

Postby fwape » March 3rd, 2021, 2:21 pm

ZeroOne wrote:
ronsin1 wrote:
TheAutoDIYGuyYT wrote:Hey guys...I have a local 2005 cs3 lancer with 4g18 and Cvt tranny. The original tranny failed on me, then I got a foreign used one from bamboo which failed after a few months...so I purchased a brand new cvt tranny about 2 years ago, however, today the transmission shift solenoids failed on me.

Is there anyone who does conversions from cvt to manual gearbox or normal auto for this model?
Wow thats a lot of bad luck

I know CVT transmission in CS3 thats lasted over 300K km without issues

Have you been changing transmission oil on time



The CVT generates a lot of heat and the SP111 oil breaks down in viscosity


I had two CS lancers with CVT transmission, I had the transmission oil changed at every 25k km to be safe and I also installed an external oil cooler


I ran mine somewhere over 50k km last time i changed it.

It throws on the engine check light and a trans oil pressure low code when you connect a scan tool and thats when I changed mine.

I only use original mitsu sp3 oil

Not saying to follow my example and go 50k km before changing, I usually change around 30k km.


Wow 3 Trannys in a few years cannot be easy on the pocket man!!! I don't know about luck and such but i have my 2003 CS3 Lancer for over 10 years now and only just looking to change the transmission oil this month actually. once I thought the CVT was going bad a few years ago and was going to have it swapped but our local transmission expert here in St. Lucia said mine was good and it was actually the exhaust manifold and coil packs causing the erratic behavior. I am going to use the local CVT fluid NP Ultra makes from Trinidad, was wondering if its any good before i go ahead and purchase it.

User avatar
ZeroOne
12 pounds of Boost
Posts: 2252
Joined: August 5th, 2008, 4:10 pm

Re: The Official CS Lancer Thread!

Postby ZeroOne » March 12th, 2021, 9:52 am

St Lucia, nice

I've never used NP tans oil, is it SP 3?

In the past I usually change trans oil about every 2-3 years but now with the pandemic im thinking 3-4 years before I reach 30k km........just checked......last trans oil change was in mar 2018 only did 17k km since.

Rayden6
3NE 2NR for life
Posts: 168
Joined: June 7th, 2005, 7:20 pm
Location: Locally

Re: The Official CS Lancer Thread!

Postby Rayden6 » August 21st, 2021, 10:38 pm

Is the CS5W disc pad the same as CY4a both front and rear?

>>>JIMM¥<<<
Riding on 13's
Posts: 1
Joined: September 15th, 2012, 5:07 am

Re: The Official CS Lancer Thread!

Postby >>>JIMM¥<<< » August 23rd, 2021, 12:05 am

Hassan wrote:Newbie here to this site. my problem is best described as copied here-under by Groundcontrol » July 20th, 2014. Has anyone found a solution.

Thanks in advance.

{Okay guys.i have a Local 2004 Mitsubishi lancer CS3.
The car has a standard 4g18 engine with a standard CVT Tranny.
My cars lacks power.Extreme loss of power.
I feel the power there but its like something is holding the car back.
When climbing inclines the cars runs out of power and sometimes won't make it up depending on the incline.And thats with a wide open throttle(pedal to the metal)
In reverse the cars barely moves.
Also if i cold start and i drive it i get this sorta jig saw back and forth feeling from the car until it warms up a bit.
The engine sounds noticably heaver when idling also.
Over the past 4 months i've been trying to tackle this issue but still the problems exists.
First off.There's no check engine light on.The car drives fine when say i'm doing 60 to 80 on the speedo but say if i decide to press for acceleration the car revs out and goes nowhere.The speed barely increases.The engine would rev but no acceleration.
Things i have tried over the past 4 months to diagnose problem include:
Take car the for engine error code scan.
Change transmission oil
Change engine oil
Change air filter
Change plugs
Change valve cover seal rubbers and gaskets.
Clean injectors
Clean throttle body
Change CAM sensor
Change Crank sensor
Change MAF sensor
Clean IAC sensor
Clean TPS sensor
Clean fuel pump filter
Check fuel pressure
Test MAF,IAC,TPS,O2 sensors manually with voltmeter
Manually inspect exhaust for clogg
Remove catalyc converter
Check engine timing.

Everything that was checked or changed or tested is and works within their intended range.No fault codes or faulty sensors.}


Going through something similar right now, changed transmission and same problem, anyone found a solution for this yet? Car drives normal when cold, but when it warms up, car barely moves (literally inches) when revving in drive or reverse, rev long enough to about 3-4k rpm and it begins to actually drive, happens in and out (not all the time)… seems to happen after a dead stop and having to accelerate from a complete stop, or if u switch from reverse to drive. Old transmission threw a blinking neutral light when it first happened, swapped out transmission and no neutral light since, but still experiencing this acceleration issue. Any help is appreciated.

Edit: it's a CS3 Lancer that originally came 4g18 CVT, put in a 4g15 a while back (used back the same transmission) and it worked fine, until this issue that started happening this week, a foreign used transmission was installed yesterday and the same problem persists.

User avatar
ZeroOne
12 pounds of Boost
Posts: 2252
Joined: August 5th, 2008, 4:10 pm

Re: The Official CS Lancer Thread!

Postby ZeroOne » August 27th, 2021, 3:14 pm

GDI engine?

Might need to do engine scan (with a proper scan tool) for error codes and perhaps a compression test.

Also check your fuel trims, long term and short term fuel trims, >10 in any one = something wrong.

User avatar
trent
Riding on 17's
Posts: 1502
Joined: May 27th, 2010, 1:18 pm

Re: The Official CS Lancer Thread!

Postby trent » August 28th, 2021, 7:44 am

Not GDI, have you all checked the ECU?
Contact this person 332 9670

suggastik
Riding on 13's
Posts: 2
Joined: December 20th, 2010, 11:34 am

Re: The Official CS Lancer Thread!

Postby suggastik » September 1st, 2021, 9:23 pm

Good day, can anyone tell me the torque specs for my 2005 4g18 cs3a lancer. Doing an engine rebuild and can't seem to find the torque specs

King Lee
Riding on 13's
Posts: 8
Joined: April 18th, 2016, 6:36 pm

Re: The Official CS Lancer Thread!

Postby King Lee » September 2nd, 2021, 7:18 pm

Goodnight. Have a 4g15 SOHC in a CS2 lancer (bought the car like this). The bolt for my cranshaft pulley keeps running slack. I have tried everything but as long as the AC compressor comes on the pilley stqrts wobblong and the bolt runs slack. Anyone ever experienced this and solved the problem? Does this mean i have to get a head and block? Does it make sense purchasing a 4g15 head and block in 2021? Please advise.

User avatar
ZeroOne
12 pounds of Boost
Posts: 2252
Joined: August 5th, 2008, 4:10 pm

Re: The Official CS Lancer Thread!

Postby ZeroOne » September 11th, 2021, 9:05 pm

suggastik wrote:Good day, can anyone tell me the torque specs for my 2005 4g18 cs3a lancer. Doing an engine rebuild and can't seem to find the torque specs


Yes I have one let me know if you want the entire overhaul manual


King Lee wrote:Goodnight. Have a 4g15 SOHC in a CS2 lancer (bought the car like this). The bolt for my cranshaft pulley keeps running slack. I have tried everything but as long as the AC compressor comes on the pilley stqrts wobblong and the bolt runs slack. Anyone ever experienced this and solved the problem? Does this mean i have to get a head and block? Does it make sense purchasing a 4g15 head and block in 2021? Please advise.


Did you inspect the threading on the block for the bolt? How does it look?

Advertisement

Return to “MITSUBISHI”

Who is online

Users browsing this forum: No registered users and 15 guests